glassfish
  1. glassfish
  2. GLASSFISH-8233

[REOPEN] <install-dir>/bin/updatetool does not work if build is re-installed in the same install directory

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: installation
    • Labels:
      None
    • Environment:

      Operating System: Mac OS X
      Platform: Other

    • Issuezilla Id:
      8,233

      Description

      Build: SDK 03a / GFv3 promoted 47a

      <install-dir>/bin/updatetool does not work if build is re-installed in the same
      install directory. It seems that <install-dir>/bin/updatetool does not get
      replaced properly. However, <install-dir>/updatetool/bin/updatetool does work.

      I am not sure if this is installer or UC issue. Please move this to the proper
      subcategory. Thanks!

      Step to reproduce:
      ------------------
      1) Install the build using the default values.
      2) Invoke <install-dir>/bin/updatetool
      3) Observe that updatetool is launched properly
      4) Quit updatetool and uninstall.exe
      (Did not have to stop appserver since did not start any. However, did not stop
      python process either prior to the uninstallation)
      5) Re-install the build using the default values.
      6) Observe that the installation is completed without any error.
      7) Invoke <install-dir>/bin/updatetool
      8) Observe that updatetool states that updatetool is not installed and asks if
      the user wants to install updatetool (???)
      10) Proceed to install updatetool.
      11) Observe that the updatetool script completes properly.
      12) Invoke <install-dir>/bin/updatetool again to launch.
      13) Observe that the cycle (step 8-13) is repeated again ... if
      <install-dir>/bin/updatetool is used.
      14) Now, invoke <install-dir>/updatetool/bin/updatetool.
      15) Observe that updatetool is launched properly

        Activity

        scatari added a comment -

        Is the installation directory completely cleaned up and notifier process stopped prior to reinstalling?

        nluu added a comment -

        No, the install directory was not completely cleaned up by the uninstaller
        (issue 6795), and I purposely did not want to manually clean it up nor to stop
        the uc notifier (step 4), since I wanted to see if the installer is able to
        install properly again in the same directory. Thus, the observation.

        scatari added a comment -

        The underlying reason is left over files and directories, when issue 6795 gets fixed, this will also be
        resolved. So closing as dup.

            • This issue has been marked as a duplicate of 6795 ***
        nluu added a comment -

        Reopen to fix for FCS, since issue 6795 is closed but does not have a real fix.

        scatari added a comment -

        The fix for this would be to let uninstaller forcefully remove ".org*" directory from under
        <InstallDirectory>. This change is required in the install wrapper.

        scatari added a comment -

        Taking ownership

        scatari added a comment -

        This will be fixed for FCS.

        scatari added a comment -

        The uninstall script has been modified to forcefully remove the ".org*" directory after uninstallation.
        But this is only for unix platforms.

        The directory(.org...) contains files with very long filenames that have unsupported characters as part of
        the filenames, hence the uninstall wrapper on windows is not able to delete this directory completely. This
        will be documented as a limitation with the workaround of instructing users to manually remove this
        hidden directory on windows.

        Marking as fixed.

        Gail Risdal added a comment -

        Added to v3 Release Notes.


          People

          • Assignee:
            scatari
            Reporter:
            nluu
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: