glassfish
  1. glassfish
  2. GLASSFISH-8566

session failover not working when instance comes back

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Trivial Trivial
    • Resolution: Unresolved
    • Affects Version/s: 9.0pe
    • Fix Version/s: not determined
    • Component/s: failover
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: Linux

    • Issuezilla Id:
      8,566

      Description

      Hello,

      I'm experiencing the same problem that was reported in issue #5106.

      I'm using Glassfish v2.1 on CentOS 5.3 x86 on VMware 3.5 ESXi with a
      HW-balancer. Simple roundrobin without persistence. (I need without persistence
      because most of the clients work behind a NATed router)

      Everything works (and i can see the messages if I configure the logger with
      FINE) with clusterjsp app.

      When i shutdown one instance and that start it up again but the instance
      restarted always create a new session.

      I can see that the restarted instance resquests (broadcasts) the session id but
      it doesn't receive a response and creates a new session.

      I can confirm that it broadcasts the request using tcpdump.

      1. server-domain.tar.gz
        17 kB
        jccosta
      2. server-node1.tar.gz
        467 kB
        jccosta
      3. server-node2.tar.gz
        545 kB
        jccosta

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            lwhite
            Reporter:
            jccosta
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: