glassfish
  1. glassfish
  2. GLASSFISH-9002

Compatibility issue: required for petstore complilation javaee.jar is absent.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: build_system
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

    • Issuezilla Id:
      9,002

      Description

      V3 build 57, Solaris 10 Sparc and petstore sample from:
      http://java.sun.com/javaee/downloads, scroll to the bottom of the page and look
      for Java Blueprints Update 6.

      The compilation of petstore failed without <AS_HOME>/lib/javaee.jar, but V3
      doesn't have this jar.

        Issue Links

          Activity

          easarina added a comment -

          This is compatibility issue

          judytangs added a comment -

          In SDK pteam meeting, we talked about raise this bug to P2 to get addressed
          first. This bug could be reporting the same issue as GLASSFISH-9054. Developer can
          take a look and decide. Thanks, Judy

          kumara added a comment -

          Need to create jar file with manifest entry Class-Path: pointing to all java ee api jars. May need to create
          another jar for web profile apis.

          judytangs added a comment -
              • Issue 9054 has been marked as a duplicate of this issue. ***
          judytangs added a comment -

          This bug is blocking SQE from testing JavaEE5 samples on v3. Hope Jane can find
          some time to look into this. The sample SCF is 9/16 by the way, so it does have
          a few days left, hope the fix is not too hard. Thanks Jane

          janey added a comment -

          working on this...

          janey added a comment -

          Fixed in svn rev 31351.

          Sanjeeb Sahoo added a comment -

          Ideally, this issue should have been closed as a duplicate of 8630, but since
          ithas been already marked RESOLVED, I am adding a dependency on this issue from
          8630, which is about both javaee.jar & appserv-rt.jar, where as this is just
          about javaee.jar.


            People

            • Assignee:
              janey
              Reporter:
              easarina
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: