glassfish
  1. glassfish
  2. GLASSFISH-9048

Unable to build domains under 1.7.0-ea

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: v2.1.1
    • Fix Version/s: None
    • Component/s: installation
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Linux

      Description

      I just installed Glassfish 2.1-b60e Jar under Ubuntu Linux 9.04 (EEEbuntu 3.0)
      and during the domain creation received the following error:

      BUILD FAILED
      /home/esmith/Apps/Glassfish-2.1/setup.xml:161: The following error occurred
      while executing this line:
      /home/esmith/Apps/Glassfish-2.1/setup.xml:151: Glassfish requires JDK 1.5 or
      higher, you have java version "1.7.0-ea"
      Java(TM) SE Runtime Environment (build 1.7.0-ea-b59)
      Java HotSpot(TM) Server VM (build 16.0-b03, mixed mode)

      It appears that the setup script cannot determine that 1.7.0 is greater than 1.5.x

        Activity

        Hide
        ne110415 added a comment -

        Changing to right component.

        Show
        ne110415 added a comment - Changing to right component.
        Hide
        Snjezana Sevo-Zenzerovic added a comment -

        Issue not applicable to v3, adjusting target milestone and exclude keyword.

        Show
        Snjezana Sevo-Zenzerovic added a comment - Issue not applicable to v3, adjusting target milestone and exclude keyword.
        Hide
        Snjezana Sevo-Zenzerovic added a comment -

        ...

        Show
        Snjezana Sevo-Zenzerovic added a comment - ...
        Hide
        Snjezana Sevo-Zenzerovic added a comment -

        ...

        Show
        Snjezana Sevo-Zenzerovic added a comment - ...
        Hide
        scatari added a comment -

        Not a bug on 3.1.1.

        Show
        scatari added a comment - Not a bug on 3.1.1.
        Hide
        stephenwilburn added a comment -

        To get around this issue I edited the setup.xml file to include my current JDK version "1.7.0_02"

        This allowed for a successful build.

        (around lines 145-150 of the setup.xml file in the % glassfish directory)

        <condition property="java.version.acceptable">
        <or>
        <contains string="$

        {targeted.java.version}" substring="1.5"/>
        <contains string="${targeted.java.version}

        " substring="1.7.0_02"/>
        </or>
        </condition>

        Show
        stephenwilburn added a comment - To get around this issue I edited the setup.xml file to include my current JDK version "1.7.0_02" This allowed for a successful build. (around lines 145-150 of the setup.xml file in the % glassfish directory) <condition property="java.version.acceptable"> <or> <contains string="$ {targeted.java.version}" substring="1.5"/> <contains string="${targeted.java.version} " substring="1.7.0_02"/> </or> </condition>

          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            esmithbss
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: