Issue Details (XML | Word | Printable)

Key: GLASSFISH-9048
Type: Bug Bug
Status: Open Open
Priority: Major Major
Assignee: Snjezana Sevo-Zenzerovic
Reporter: esmithbss
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

Unable to build domains under 1.7.0-ea

Created: 06/Aug/09 09:17 AM   Updated: 28/Dec/11 06:12 PM
Component/s: installation
Affects Version/s: v2.1.1
Fix Version/s: None

Time Tracking:
Not Specified

Environment:

Operating System: All
Platform: Linux


Issuezilla Id: 9,048
Status Whiteboard:

v3_exclude

Tags: 3_1-exclude future-exclude
Participants: esmithbss, ne110415, scatari, Snjezana Sevo-Zenzerovic and stephenwilburn


 Description  « Hide

I just installed Glassfish 2.1-b60e Jar under Ubuntu Linux 9.04 (EEEbuntu 3.0)
and during the domain creation received the following error:

BUILD FAILED
/home/esmith/Apps/Glassfish-2.1/setup.xml:161: The following error occurred
while executing this line:
/home/esmith/Apps/Glassfish-2.1/setup.xml:151: Glassfish requires JDK 1.5 or
higher, you have java version "1.7.0-ea"
Java(TM) SE Runtime Environment (build 1.7.0-ea-b59)
Java HotSpot(TM) Server VM (build 16.0-b03, mixed mode)

It appears that the setup script cannot determine that 1.7.0 is greater than 1.5.x



ne110415 added a comment - 19/Aug/09 07:36 PM

Changing to right component.


Snjezana Sevo-Zenzerovic added a comment - 14/Sep/09 02:08 PM

Issue not applicable to v3, adjusting target milestone and exclude keyword.


Snjezana Sevo-Zenzerovic added a comment - 30/Aug/10 02:49 PM

...


Snjezana Sevo-Zenzerovic added a comment - 30/Aug/10 03:01 PM

...


kenaiadmin made changes - 26/Nov/10 12:05 AM
Field Original Value New Value
issue.field.bugzillaimportkey 9048 40652
Chris Kasso made changes - 06/Jan/11 10:33 AM
Fix Version/s v2.1.2 [ 10979 ]
scatari added a comment - 05/Jul/11 01:18 AM

Not a bug on 3.1.1.


scatari made changes - 05/Jul/11 01:18 AM
Priority Critical [ 2 ] Major [ 3 ]
stephenwilburn added a comment - 28/Dec/11 06:12 PM

To get around this issue I edited the setup.xml file to include my current JDK version "1.7.0_02"

This allowed for a successful build.

(around lines 145-150 of the setup.xml file in the % glassfish directory)

<condition property="java.version.acceptable">
<or>
<contains string="${targeted.java.version}" substring="1.5"/>
<contains string="${targeted.java.version}" substring="1.7.0_02"/>
</or>
</condition>