glassfish
  1. glassfish
  2. GLASSFISH-9057

AS Cluster Instances startup failure caused by failure in starting MQ Brokers

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: v2.1.1
    • Fix Version/s: v2.1.1
    • Component/s: jms
    • Labels:
      None
    • Environment:

      Operating System: other
      Platform: Sun

    • Issuezilla Id:
      9,057

      Description

      V2.1.1 B24 & B26
      Windows 2003 Adv Svr
      Application: Richaccess

      After setting up 3 instance cluster on windows 2003 svr, the following mq
      connection issue is seen during startup of cluster. This issue seems to be on
      windows 2003 svr. I tested B24 on X86 and Suse and did not observe this issue on
      those 2 platforms.

      4 windows machines setup => 1 for DAS, 1 for instance1, 1 for instance2 and 1
      for instance3

      Here are the steps done:

      1) Create domain sqe-domain and start domain
      2) Create cluster
      3) Create node agents on each instance machine: agent1, agent2 and agent3
      4) Create instance1, instance2 and instance3
      5) Set agent start_servers_in_startup = false
      6) Create file "test" user for Richaccess
      7) Create jvm options, tunings and jms resources for Richaccess
      8) Deploy application
      9) Restart sqe-domain
      10) Start all node agents from each instance machine
      11) Start Cluster from admin gui and the following error is seen in server logs:

      Snippet from Instance1 log
      **************************
      [#|2009-08-06T15:24:40.732-0700|WARNING|sun-appserver2.1|javax.enterprise.system.stream.err|_ThreadID=10;_ThreadName=main;_RequestID=5015b5a8-6b8e-4cd7-897e-c4474a95f5ff;|java.io.IOException:
      CreateProcess: C:\as\imq\bin\imqbrokersvc.exe -javahome C:\Java\jdk1.5.0_19
      -Dimq.cluster.masterbroker=mq://bigapp-pc9:37676/
      -Dimq.cluster.brokerlist=mq://bigapp-pc9:37676/,mq://jws-orion-pc-4.red.iplanet.com:37676/,mq://bigapp-pc10:37676/
      -Dimq.cluster.nowaitForMasterBroker=true -varhome
      C:\as\nodeagents\agent1\instance1\imq -startRmiRegistry -rmiRegistryPort 37776
      -Dimq.imqcmd.user=admin -passfile C:\temp\asmq8886553258607347241.tmp -save
      -name richaccesswinclusterinstance1 -console -port 37676 -bgnd -silent error=14001
      at java.lang.ProcessImpl.create(Native Method)
      at java.lang.ProcessImpl.<init>(ProcessImpl.java:81)
      at java.lang.ProcessImpl.start(ProcessImpl.java:30)
      at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
      at java.lang.Runtime.exec(Runtime.java:591)
      at java.lang.Runtime.exec(Runtime.java:464)
      at
      com.sun.messaging.jmq.admin.jmsspi.JMSAdminImpl.startProvider(JMSAdminImpl.java:808)
      at com.sun.messaging.jms.ra.LocalBrokerRunner.start(LocalBrokerRunner.java:305)
      at
      com.sun.messaging.jms.ra.LifecycleManagedBroker.start(LifecycleManagedBroker.java:306)
      at com.sun.messaging.jms.ra.ResourceAdapter.start(ResourceAdapter.java:302)
      at
      com.sun.enterprise.connectors.ActiveInboundResourceAdapter$1.run(ActiveInboundResourceAdapter.java:180)
      at java.security.AccessController.doPrivileged(Native Method)
      at
      com.sun.enterprise.connectors.ActiveInboundResourceAdapter.startResourceAdapter(ActiveInboundResourceAdapter.java:174)
      at
      com.sun.enterprise.connectors.ActiveInboundResourceAdapter.<init>(ActiveInboundResourceAdapter.java:132)
      at
      com.sun.enterprise.connectors.system.ActiveJmsResourceAdapter.<init>(ActiveJmsResourceAdapter.java:234)
      at
      com.sun.enterprise.connectors.ActiveRAFactory.createActiveResourceAdapter(ActiveRAFactory.java:107)
      at
      com.sun.enterprise.connectors.ResourceAdapterAdminServiceImpl.createActiveResourceAdapter(ResourceAdapterAdminServiceImpl.java:300)
      at
      com.sun.enterprise.connectors.ResourceAdapterAdminServiceImpl.createActiveResourceAdapter(ResourceAdapterAdminServiceImpl.java:445)
      at
      com.sun.enterprise.connectors.ConnectorRuntime.createActiveResourceAdapter(ConnectorRuntime.java:230)
      at
      com.sun.enterprise.jms.JmsProviderLifecycle.onStartup(JmsProviderLifecycle.java:451)
      at
      com.sun.enterprise.server.ApplicationServer.onStartup(ApplicationServer.java:449)
      at
      com.sun.enterprise.server.ondemand.OnDemandServer.onStartup(OnDemandServer.java:134)
      at com.sun.enterprise.server.PEMain.run(PEMain.java:409)
      at com.sun.enterprise.server.PEMain.main(PEMain.java:336)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.sun.enterprise.server.PELaunch.main(PELaunch.java:415)

      #]

      [#|2009-08-06T15:24:40.748-0700|SEVERE|sun-appserver2.1|javax.enterprise.resource.resourceadapter|_ThreadID=10;_ThreadName=main;_RequestID=5015b5a8-6b8e-4cd7-897e-c4474a95f5ff;|RAR6035
      : Resource adapter start failed :

      {0}

      javax.resource.spi.ResourceAdapterInternalException: MQJMSRA_RA4001:
      start:Aborting:Exception starting LOCAL broker=CreateProcess:
      C:\as\imq\bin\imqbrokersvc.exe -javahome C:\Java\jdk1.5.0_19
      -Dimq.cluster.masterbroker=mq://bigapp-pc9:37676/
      -Dimq.cluster.brokerlist=mq://bigapp-pc9:37676/,mq://jws-orion-pc-4.red.iplanet.com:37676/,mq://bigapp-pc10:37676/
      -Dimq.cluster.nowaitForMasterBroker=true -varhome
      C:\as\nodeagents\agent1\instance1\imq -startRmiRegistry -rmiRegistryPort 37776
      -Dimq.imqcmd.user=admin -passfile C:\temp\asmq8886553258607347241.tmp -save
      -name richaccesswinclusterinstance1 -console -port 37676 -bgnd -silent error=14001
      at
      com.sun.messaging.jms.ra.LifecycleManagedBroker.start(LifecycleManagedBroker.java:309)
      at com.sun.messaging.jms.ra.ResourceAdapter.start(ResourceAdapter.java:302)
      at
      com.sun.enterprise.connectors.ActiveInboundResourceAdapter$1.run(ActiveInboundResourceAdapter.java:180)
      at java.security.AccessController.doPrivileged(Native Method)
      at
      com.sun.enterprise.connectors.ActiveInboundResourceAdapter.startResourceAdapter(ActiveInboundResourceAdapter.java:174)
      at
      com.sun.enterprise.connectors.ActiveInboundResourceAdapter.<init>(ActiveInboundResourceAdapter.java:132)
      at
      com.sun.enterprise.connectors.system.ActiveJmsResourceAdapter.<init>(ActiveJmsResourceAdapter.java:234)
      at
      com.sun.enterprise.connectors.ActiveRAFactory.createActiveResourceAdapter(ActiveRAFactory.java:107)
      at
      com.sun.enterprise.connectors.ResourceAdapterAdminServiceImpl.createActiveResourceAdapter(ResourceAdapterAdminServiceImpl.java:300)
      at
      com.sun.enterprise.connectors.ResourceAdapterAdminServiceImpl.createActiveResourceAdapter(ResourceAdapterAdminServiceImpl.java:445)
      at
      com.sun.enterprise.connectors.ConnectorRuntime.createActiveResourceAdapter(ConnectorRuntime.java:230)
      at
      com.sun.enterprise.jms.JmsProviderLifecycle.onStartup(JmsProviderLifecycle.java:451)
      at
      com.sun.enterprise.server.ApplicationServer.onStartup(ApplicationServer.java:449)
      at
      com.sun.enterprise.server.ondemand.OnDemandServer.onStartup(OnDemandServer.java:134)
      at com.sun.enterprise.server.PEMain.run(PEMain.java:409)
      at com.sun.enterprise.server.PEMain.main(PEMain.java:336)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.sun.enterprise.server.PELaunch.main(PELaunch.java:415)
      Caused by: java.io.IOException: CreateProcess: C:\as\imq\bin\imqbrokersvc.exe
      -javahome C:\Java\jdk1.5.0_19 -Dimq.cluster.masterbroker=mq://bigapp-pc9:37676/
      -Dimq.cluster.brokerlist=mq://bigapp-pc9:37676/,mq://jws-orion-pc-4.red.iplanet.com:37676/,mq://bigapp-pc10:37676/
      -Dimq.cluster.nowaitForMasterBroker=true -varhome
      C:\as\nodeagents\agent1\instance1\imq -startRmiRegistry -rmiRegistryPort 37776
      -Dimq.imqcmd.user=admin -passfile C:\temp\asmq8886553258607347241.tmp -save
      -name richaccesswinclusterinstance1 -console -port 37676 -bgnd -silent error=14001
      at java.lang.ProcessImpl.create(Native Method)
      at java.lang.ProcessImpl.<init>(ProcessImpl.java:81)
      at java.lang.ProcessImpl.start(ProcessImpl.java:30)
      at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
      at java.lang.Runtime.exec(Runtime.java:591)
      at java.lang.Runtime.exec(Runtime.java:464)
      at
      com.sun.messaging.jmq.admin.jmsspi.JMSAdminImpl.startProvider(JMSAdminImpl.java:808)
      at com.sun.messaging.jms.ra.LocalBrokerRunner.start(LocalBrokerRunner.java:305)
      at
      com.sun.messaging.jms.ra.LifecycleManagedBroker.start(LifecycleManagedBroker.java:306)
      ... 20 more

      #]

      [#|2009-08-06T15:24:40.764-0700|WARNING|sun-appserver2.1|javax.enterprise.system.stream.err|_ThreadID=10;_ThreadName=main;_RequestID=5015b5a8-6b8e-4cd7-897e-c4474a95f5ff;|
      com.sun.enterprise.connectors.ConnectorRuntimeException: Failed to start
      resource adapter : MQJMSRA_RA4001: start:Aborting:Exception starting LOCAL
      broker=CreateProcess: C:\as\imq\bin\imqbrokersvc.exe -javahome
      C:\Java\jdk1.5.0_19 -Dimq.cluster.masterbroker=mq://bigapp-pc9:37676/
      -Dimq.cluster.brokerlist=mq://bigapp-pc9:37676/,mq://jws-orion-pc-4.red.iplanet.com:37676/,mq://bigapp-pc10:37676/
      -Dimq.cluster.nowaitForMasterBroker=true -varhome
      C:\as\nodeagents\agent1\instance1\imq -startRmiRegistry -rmiRegistryPort 37776
      -Dimq.imqcmd.user=admin -passfile C:\temp\asmq8886553258607347241.tmp -save
      -name richaccesswinclusterinstance1 -console -port 37676 -bgnd -silent error=14001
      at
      com.sun.enterprise.connectors.ActiveInboundResourceAdapter.<init>(ActiveInboundResourceAdapter.java:148)
      at
      com.sun.enterprise.connectors.system.ActiveJmsResourceAdapter.<init>(ActiveJmsResourceAdapter.java:234)
      at
      com.sun.enterprise.connectors.ActiveRAFactory.createActiveResourceAdapter(ActiveRAFactory.java:107)
      at
      com.sun.enterprise.connectors.ResourceAdapterAdminServiceImpl.createActiveResourceAdapter(ResourceAdapterAdminServiceImpl.java:300)
      at
      com.sun.enterprise.connectors.ResourceAdapterAdminServiceImpl.createActiveResourceAdapter(ResourceAdapterAdminServiceImpl.java:445)
      at
      com.sun.enterprise.connectors.ConnectorRuntime.createActiveResourceAdapter(ConnectorRuntime.java:230)
      at
      com.sun.enterprise.jms.JmsProviderLifecycle.onStartup(JmsProviderLifecycle.java:451)
      at
      com.sun.enterprise.server.ApplicationServer.onStartup(ApplicationServer.java:449)
      at
      com.sun.enterprise.server.ondemand.OnDemandServer.onStartup(OnDemandServer.java:134)
      at com.sun.enterprise.server.PEMain.run(PEMain.java:409)
      at com.sun.enterprise.server.PEMain.main(PEMain.java:336)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.sun.enterprise.server.PELaunch.main(PELaunch.java:415)
      Caused by: javax.resource.spi.ResourceAdapterInternalException: MQJMSRA_RA4001:
      start:Aborting:Exception starting LOCAL broker=CreateProcess:
      C:\as\imq\bin\imqbrokersvc.exe -javahome C:\Java\jdk1.5.0_19
      -Dimq.cluster.masterbroker=mq://bigapp-pc9:37676/
      -Dimq.cluster.brokerlist=mq://bigapp-pc9:37676/,mq://jws-orion-pc-4.red.iplanet.com:37676/,mq://bigapp-pc10:37676/
      -Dimq.cluster.nowaitForMasterBroker=true -varhome
      C:\as\nodeagents\agent1\instance1\imq -startRmiRegistry -rmiRegistryPort 37776
      -Dimq.imqcmd.user=admin -passfile C:\temp\asmq8886553258607347241.tmp -save
      -name richaccesswinclusterinstance1 -console -port 37676 -bgnd -silent error=14001
      at
      com.sun.messaging.jms.ra.LifecycleManagedBroker.start(LifecycleManagedBroker.java:309)
      at com.sun.messaging.jms.ra.ResourceAdapter.start(ResourceAdapter.java:302)
      at
      com.sun.enterprise.connectors.ActiveInboundResourceAdapter$1.run(ActiveInboundResourceAdapter.java:180)
      at java.security.AccessController.doPrivileged(Native Method)
      at
      com.sun.enterprise.connectors.ActiveInboundResourceAdapter.startResourceAdapter(ActiveInboundResourceAdapter.java:174)
      at
      com.sun.enterprise.connectors.ActiveInboundResourceAdapter.<init>(ActiveInboundResourceAdapter.java:132)
      ... 15 more
      Caused by: java.io.IOException: CreateProcess: C:\as\imq\bin\imqbrokersvc.exe
      -javahome C:\Java\jdk1.5.0_19 -Dimq.cluster.masterbroker=mq://bigapp-pc9:37676/
      -Dimq.cluster.brokerlist=mq://bigapp-pc9:37676/,mq://jws-orion-pc-4.red.iplanet.com:37676/,mq://bigapp-pc10:37676/
      -Dimq.cluster.nowaitForMasterBroker=true -varhome
      C:\as\nodeagents\agent1\instance1\imq -startRmiRegistry -rmiRegistryPort 37776
      -Dimq.imqcmd.user=admin -passfile C:\temp\asmq8886553258607347241.tmp -save
      -name richaccesswinclusterinstance1 -console -port 37676 -bgnd -silent error=14001
      at java.lang.ProcessImpl.create(Native Method)
      at java.lang.ProcessImpl.<init>(ProcessImpl.java:81)
      at java.lang.ProcessImpl.start(ProcessImpl.java:30)
      at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
      at java.lang.Runtime.exec(Runtime.java:591)
      at java.lang.Runtime.exec(Runtime.java:464)
      at
      com.sun.messaging.jmq.admin.jmsspi.JMSAdminImpl.startProvider(JMSAdminImpl.java:808)
      at com.sun.messaging.jms.ra.LocalBrokerRunner.start(LocalBrokerRunner.java:305)
      at
      com.sun.messaging.jms.ra.LifecycleManagedBroker.start(LifecycleManagedBroker.java:306)
      ... 20 more

      #]

      [#|2009-08-06T15:24:40.764-0700|INFO|sun-appserver2.1|javax.enterprise.resource.jms|_ThreadID=10;_ThreadName=main;|Failed
      to start or connect JMS RA|#]

      [#|2009-08-06T15:24:40.764-0700|INFO|sun-appserver2.1|javax.enterprise.resource.jms|_ThreadID=10;_ThreadName=main;|If
      MQ is configured as REMOTE and don't want to start MQ broker then set jvm-option
      com.sun.enterprise.jms.DONT_CONNECT_MQ_IN_REMOTE_MODE to true|#]

      [#|2009-08-06T15:24:40.764-0700|SEVERE|sun-appserver2.1|javax.enterprise.system.core|_ThreadID=10;_ThreadName=main;com.sun.enterprise.jms.JmsProviderLifecycle@133650d;com.sun.appserv.server.ServerLifecycleException:
      Failed to start JMS RA;_RequestID=5015b5a8-6b8e-4cd7-897e-c4474a95f5ff;|Service
      com.sun.enterprise.jms.JmsProviderLifecycle@133650d cannot be started! :
      com.sun.appserv.server.ServerLifecycleException: Failed to start JMS RA|#]

      [#|2009-08-06T15:24:40.764-0700|SEVERE|sun-appserver2.1|javax.enterprise.system.core|_ThreadID=10;_ThreadName=main;_RequestID=5015b5a8-6b8e-4cd7-897e-c4474a95f5ff;|CORE5071:
      An error occured during initialization
      com.sun.appserv.server.ServerLifecycleException: Failed to start JMS RA
      at
      com.sun.enterprise.jms.JmsProviderLifecycle.onStartup(JmsProviderLifecycle.java:459)
      at
      com.sun.enterprise.server.ApplicationServer.onStartup(ApplicationServer.java:449)
      at
      com.sun.enterprise.server.ondemand.OnDemandServer.onStartup(OnDemandServer.java:134)
      at com.sun.enterprise.server.PEMain.run(PEMain.java:409)
      at com.sun.enterprise.server.PEMain.main(PEMain.java:336)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.sun.enterprise.server.PELaunch.main(PELaunch.java:415)
      Caused by: com.sun.enterprise.connectors.ConnectorRuntimeException: Failed to
      start resource adapter : MQJMSRA_RA4001: start:Aborting:Exception starting LOCAL
      broker=CreateProcess: C:\as\imq\bin\imqbrokersvc.exe -javahome
      C:\Java\jdk1.5.0_19 -Dimq.cluster.masterbroker=mq://bigapp-pc9:37676/
      -Dimq.cluster.brokerlist=mq://bigapp-pc9:37676/,mq://jws-orion-pc-4.red.iplanet.com:37676/,mq://bigapp-pc10:37676/
      -Dimq.cluster.nowaitForMasterBroker=true -varhome
      C:\as\nodeagents\agent1\instance1\imq -startRmiRegistry -rmiRegistryPort 37776
      -Dimq.imqcmd.user=admin -passfile C:\temp\asmq8886553258607347241.tmp -save
      -name richaccesswinclusterinstance1 -console -port 37676 -bgnd -silent error=14001
      at
      com.sun.enterprise.connectors.ActiveInboundResourceAdapter.<init>(ActiveInboundResourceAdapter.java:148)
      at
      com.sun.enterprise.connectors.system.ActiveJmsResourceAdapter.<init>(ActiveJmsResourceAdapter.java:234)
      at
      com.sun.enterprise.connectors.ActiveRAFactory.createActiveResourceAdapter(ActiveRAFactory.java:107)
      at
      com.sun.enterprise.connectors.ResourceAdapterAdminServiceImpl.createActiveResourceAdapter(ResourceAdapterAdminServiceImpl.java:300)
      at
      com.sun.enterprise.connectors.ResourceAdapterAdminServiceImpl.createActiveResourceAdapter(ResourceAdapterAdminServiceImpl.java:445)
      at
      com.sun.enterprise.connectors.ConnectorRuntime.createActiveResourceAdapter(ConnectorRuntime.java:230)
      at
      com.sun.enterprise.jms.JmsProviderLifecycle.onStartup(JmsProviderLifecycle.java:451)
      ... 9 more
      Caused by: javax.resource.spi.ResourceAdapterInternalException: MQJMSRA_RA4001:
      start:Aborting:Exception starting LOCAL broker=CreateProcess:
      C:\as\imq\bin\imqbrokersvc.exe -javahome C:\Java\jdk1.5.0_19
      -Dimq.cluster.masterbroker=mq://bigapp-pc9:37676/
      -Dimq.cluster.brokerlist=mq://bigapp-pc9:37676/,mq://jws-orion-pc-4.red.iplanet.com:37676/,mq://bigapp-pc10:37676/
      -Dimq.cluster.nowaitForMasterBroker=true -varhome
      C:\as\nodeagents\agent1\instance1\imq -startRmiRegistry -rmiRegistryPort 37776
      -Dimq.imqcmd.user=admin -passfile C:\temp\asmq8886553258607347241.tmp -save
      -name richaccesswinclusterinstance1 -console -port 37676 -bgnd -silent error=14001
      at
      com.sun.messaging.jms.ra.LifecycleManagedBroker.start(LifecycleManagedBroker.java:309)
      at com.sun.messaging.jms.ra.ResourceAdapter.start(ResourceAdapter.java:302)
      at
      com.sun.enterprise.connectors.ActiveInboundResourceAdapter$1.run(ActiveInboundResourceAdapter.java:180)
      at java.security.AccessController.doPrivileged(Native Method)
      at
      com.sun.enterprise.connectors.ActiveInboundResourceAdapter.startResourceAdapter(ActiveInboundResourceAdapter.java:174)
      at
      com.sun.enterprise.connectors.ActiveInboundResourceAdapter.<init>(ActiveInboundResourceAdapter.java:132)
      ... 15 more
      Caused by: java.io.IOException: CreateProcess: C:\as\imq\bin\imqbrokersvc.exe
      -javahome C:\Java\jdk1.5.0_19 -Dimq.cluster.masterbroker=mq://bigapp-pc9:37676/
      -Dimq.cluster.brokerlist=mq://bigapp-pc9:37676/,mq://jws-orion-pc-4.red.iplanet.com:37676/,mq://bigapp-pc10:37676/
      -Dimq.cluster.nowaitForMasterBroker=true -varhome
      C:\as\nodeagents\agent1\instance1\imq -startRmiRegistry -rmiRegistryPort 37776
      -Dimq.imqcmd.user=admin -passfile C:\temp\asmq8886553258607347241.tmp -save
      -name richaccesswinclusterinstance1 -console -port 37676 -bgnd -silent error=14001
      at java.lang.ProcessImpl.create(Native Method)
      at java.lang.ProcessImpl.<init>(ProcessImpl.java:81)
      at java.lang.ProcessImpl.start(ProcessImpl.java:30)
      at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
      at java.lang.Runtime.exec(Runtime.java:591)
      at java.lang.Runtime.exec(Runtime.java:464)
      at
      com.sun.messaging.jmq.admin.jmsspi.JMSAdminImpl.startProvider(JMSAdminImpl.java:808)
      at com.sun.messaging.jms.ra.LocalBrokerRunner.start(LocalBrokerRunner.java:305)
      at
      com.sun.messaging.jms.ra.LifecycleManagedBroker.start(LifecycleManagedBroker.java:306)
      ... 20 more

      #]

      [#|2009-08-06T15:24:40.779-0700|SEVERE|sun-appserver2.1|javax.enterprise.system.core|_ThreadID=10;_ThreadName=main;_RequestID=5015b5a8-6b8e-4cd7-897e-c4474a95f5ff;|Server
      Startup failed. Exiting...|#]

      [#|2009-08-06T15:24:40.779-0700|INFO|sun-appserver2.1|javax.enterprise.system.core|_ThreadID=10;_ThreadName=main;|Server
      shutdown in progress...|#]

      [#|2009-08-06T15:24:40.857-0700|INFO|sun-appserver2.1|javax.enterprise.system.container.web|_ThreadID=10;_ThreadName=main;Sun
      GlassFish Enterprise Server v2.1.1;|WEB0303: Stopping Sun GlassFish Enterprise
      Server v2.1.1|#]

      [#|2009-08-06T15:24:40.857-0700|WARNING|sun-appserver2.1|javax.enterprise.system.core|_ThreadID=10;_ThreadName=main;_RequestID=5015b5a8-6b8e-4cd7-897e-c4474a95f5ff;|CORE5061:
      Exception :
      com.sun.appserv.server.ServerLifecycleException: WEB0106: An error occurred
      while stopping the web container
      at com.sun.enterprise.web.PEWebContainer.stopInstance(PEWebContainer.java:826)
      at
      com.sun.enterprise.web.PEWebContainerLifecycle.onShutdown(PEWebContainerLifecycle.java:100)
      at
      com.sun.enterprise.server.ApplicationServer.onShutdown(ApplicationServer.java:560)
      at
      com.sun.enterprise.server.ondemand.OnDemandServer.onShutdown(OnDemandServer.java:145)
      at com.sun.enterprise.server.PEMain.run(PEMain.java:427)
      at com.sun.enterprise.server.PEMain.main(PEMain.java:336)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.sun.enterprise.server.PELaunch.main(PELaunch.java:415)
      Caused by: LifecycleException: WEB0103: This web container has not yet been started
      at com.sun.enterprise.web.WebContainer.stop(WebContainer.java:913)
      at com.sun.enterprise.web.PEWebContainer.stopInstance(PEWebContainer.java:818)
      ... 10 more

      #]

      [#|2009-08-06T15:24:40.873-0700|INFO|sun-appserver2.1|javax.enterprise.system.core|_ThreadID=10;_ThreadName=main;|CORE5051:
      Shutting down all J2EE applications ...|#]

      [#|2009-08-06T15:24:40.873-0700|INFO|sun-appserver2.1|javax.enterprise.system.core|_ThreadID=10;_ThreadName=main;|CORE5068
      : Stopping all J2EE Connector 1.5 Compliant resource adapters ...|#]

      [#|2009-08-06T15:24:40.873-0700|INFO|sun-appserver2.1|javax.enterprise.system.core|_ThreadID=10;_ThreadName=main;|CORE
      5061 : Resource adapters Stop() Complete|#]

      [#|2009-08-06T15:24:40.873-0700|INFO|sun-appserver2.1|javax.enterprise.system.core|_ThreadID=10;_ThreadName=main;|CORE5052:
      Application shutdown complete.|#]

      [#|2009-08-06T15:24:40.873-0700|WARNING|sun-appserver2.1|javax.enterprise.system.core|_ThreadID=10;_ThreadName=main;_RequestID=5015b5a8-6b8e-4cd7-897e-c4474a95f5ff;|CORE5061:
      Exception :
      java.lang.NullPointerException
      at
      com.sun.enterprise.util.InvocationManagerImpl.preInvoke(InvocationManagerImpl.java:136)
      at
      com.sun.appserv.server.ServerLifecycleModule.preInvoke(ServerLifecycleModule.java:178)
      at
      com.sun.appserv.server.ServerLifecycleModule.postEvent(ServerLifecycleModule.java:219)
      at
      com.sun.appserv.server.ServerLifecycleModule.onShutdown(ServerLifecycleModule.java:273)
      at
      com.sun.appserv.server.LifecycleModuleService.onShutdown(LifecycleModuleService.java:487)
      at
      com.sun.enterprise.server.ApplicationServer.onShutdown(ApplicationServer.java:560)
      at
      com.sun.enterprise.server.ondemand.OnDemandServer.onShutdown(OnDemandServer.java:145)
      at com.sun.enterprise.server.PEMain.run(PEMain.java:427)
      at com.sun.enterprise.server.PEMain.main(PEMain.java:336)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.sun.enterprise.server.PELaunch.main(PELaunch.java:415)

      #]

      [#|2009-08-06T15:24:40.904-0700|INFO|sun-appserver2.1|ShoalLogger|_ThreadID=10;_ThreadName=main;richaccess-win-cluster;|Leaving
      GMS group richaccess-win-cluster with shutdown type set to InstanceShutdown|#]

      [#|2009-08-06T15:24:41.592-0700|WARNING|sun-appserver2.1|javax.enterprise.system.core|_ThreadID=10;_ThreadName=main;_RequestID=5015b5a8-6b8e-4cd7-897e-c4474a95f5ff;|CORE5061:
      Exception :
      java.lang.NullPointerException
      at
      com.sun.enterprise.util.InvocationManagerImpl.preInvoke(InvocationManagerImpl.java:136)
      at
      com.sun.appserv.server.ServerLifecycleModule.preInvoke(ServerLifecycleModule.java:178)
      at
      com.sun.appserv.server.ServerLifecycleModule.postEvent(ServerLifecycleModule.java:219)
      at
      com.sun.appserv.server.ServerLifecycleModule.onTermination(ServerLifecycleModule.java:277)
      at
      com.sun.appserv.server.LifecycleModuleService.onTermination(LifecycleModuleService.java:496)
      at
      com.sun.enterprise.server.ApplicationServer.onTermination(ApplicationServer.java:598)
      at com.sun.enterprise.server.PEMain.run(PEMain.java:432)
      at com.sun.enterprise.server.PEMain.main(PEMain.java:336)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.sun.enterprise.server.PELaunch.main(PELaunch.java:415)

      #]

      [#|2009-08-06T15:24:41.607-0700|SEVERE|sun-appserver2.1|javax.enterprise.system.core|_ThreadID=10;_ThreadName=main;_RequestID=5015b5a8-6b8e-4cd7-897e-c4474a95f5ff;|Server
      stopped due to Server startup failure.|#]

      On same setup, I tried the following simple steps and could reproduce the issue.

      1) Create new domain called test-domain on das machine and start domain
      2) Create cluster test-cluster
      3) Create nodeagents on each instance machine: test-agent1, test-agent2 and
      test-agent3
      4) Restart test-domain
      5) Set agent start_servers_in_startup = false
      6) Start nodeagents on each instance machine
      7) Start Cluster from admin gui and the above error is seen on instance logs.

        Activity

        meenap added a comment -

        Changing target milestone to V2.1.1

        meenap added a comment -

        I just tried setting up Cluster Profile on Suse using B27. Cluster startup is
        working fine on Suse without any issues. So this issue seems to be related to
        Windows platform.

        Satish Kumar added a comment -

        You appear to be hitting the Windows issue (8771) with MQ 4.4. You will need to
        update certain libs that are available from the following link before running
        the app server. More details are part of issue 8771.

        http://www.microsoft.com/downloads/details.aspx?familyid=9B2DA534-3E03-4391-
        8A4D-074B9F2BC1BF&displaylang=en

        Marking this as a duplicate of GF issue 8771

            • This issue has been marked as a duplicate of 8771 ***

          People

          • Assignee:
            Satish Kumar
            Reporter:
            meenap
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: