Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: v2.2
    • Fix Version/s: V3
    • Component/s: performance
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

    • Issuezilla Id:
      9,106
    • Status Whiteboard:

      v3_exclude

      Show
      v3_exclude

      Description

      Glassfish V2.1.1 B27 Cluster Profile
      JDK1.5.0_19
      SpecJ 2004 application
      SuSE 10
      4 instance clusters

      When running 24X7 test using benchmark application, SpecJ 2004, the following
      exception is seen in instance2 and instance4 after about 5 days 14 hours into
      the run. The run is still going on.

      [#|2009-08-12T08:32:38.478-0700|INFO|sun-appserver2.1|javax.enterprise.system.container.ejb|_ThreadID=19;_ThreadName=httpSSLWorkerThread-38080-2;ItemBrowserSes;|EJB5018:
      An exception was thrown during an ejb invocation on [ItemBrowserSes]|#]

      [#|2009-08-12T08:32:38.483-0700|INFO|sun-appserver2.1|javax.enterprise.system.container.ejb|_ThreadID=19;_ThreadName=httpSSLWorkerThread-38080-2;|
      javax.ejb.EJBException
      at
      com.sun.ejb.containers.BaseContainer.processSystemException(BaseContainer.java:3903)
      at
      com.sun.ejb.containers.BaseContainer.completeNewTx(BaseContainer.java:3803)
      at
      com.sun.ejb.containers.BaseContainer.postInvokeTx(BaseContainer.java:3605)
      at
      com.sun.ejb.containers.StatefulSessionContainer.postInvokeTx(StatefulSessionContainer.java:1377)
      at com.sun.ejb.containers.BaseContainer.postInvoke(BaseContainer.java:1388)
      at com.sun.ejb.containers.BaseContainer.postInvoke(BaseContainer.java:1325)
      at
      com.sun.ejb.containers.EJBLocalObjectInvocationHandler.invoke(EJBLocalObjectInvocationHandler.java:205)
      at
      com.sun.ejb.containers.EJBLocalObjectInvocationHandler.invoke(EJBLocalObjectInvocationHandler.java:134)
      at $Proxy41.browseReverse(Unknown Source)
      at
      org.spec.jappserver.servlet.helper.SpecAction_Local.getVehicleQuotes(SpecAction_Local.java:363)
      at
      org.spec.jappserver.servlet.helper.SpecServletAction.doVehicleQuotes(SpecServletAction.java:653)
      at
      org.spec.jappserver.servlet.SpecAppServlet.performTask(SpecAppServlet.java:197)
      at org.spec.jappserver.servlet.SpecAppServlet.doGet(SpecAppServlet.java:96)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:734)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:427)
      at
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:315)
      at
      org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:287)
      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:218)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94)
      at
      com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.java:98)
      at
      org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:222)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1096)
      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:166)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1096)
      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:166)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1096)
      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:291)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:666)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:597)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:871)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:341)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:263)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:214)
      at
      com.sun.enterprise.web.portunif.PortUnificationPipeline$PUTask.doTask(PortUnificationPipeline.java:380)
      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:265)
      at
      com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:106)
      Caused by: java.lang.ArrayIndexOutOfBoundsException: -9
      at java.util.ArrayList.get(ArrayList.java:323)
      at
      org.spec.jappserver.orders.itemBrowserSes.ejb.ItemBrowserSesEJB.browseReverse(ItemBrowserSesEJB.java:199)
      at sun.reflect.GeneratedMethodAccessor187.invoke(Unknown Source)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at
      com.sun.enterprise.security.application.EJBSecurityManager.runMethod(EJBSecurityManager.java:1011)
      at com.sun.enterprise.security.SecurityUtil.invoke(SecurityUtil.java:175)
      at
      com.sun.ejb.containers.BaseContainer.invokeTargetBeanMethod(BaseContainer.java:2929)
      at com.sun.ejb.containers.BaseContainer.intercept(BaseContainer.java:4020)
      at
      com.sun.ejb.containers.EJBLocalObjectInvocationHandler.invoke(EJBLocalObjectInvocationHandler.java:197)
      ... 36 more

      #]

        Activity

        Ed Bratt added a comment -

        Really ... v2.2

        kumara added a comment -

        Not a v3 product issue and hence excluded from defect tracking.

        meenap added a comment -

        Ran SpecJ on B31c for 7 days. The ArrayIndexOutOfBoundsException was not
        reproducible in this build.

        Nazrul added a comment -

        Requesting Marina to scrub this issue

        marina vatkina added a comment -

        Please reopen if reproduced on 3.1


          People

          • Assignee:
            marina vatkina
            Reporter:
            meenap
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: