glassfish
  1. glassfish
  2. GLASSFISH-9554

Jar archiver failure on hk2-jar build with long russian description in POM

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: V3
    • Fix Version/s: 3.1
    • Component/s: build_system
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Linux

    • Issuezilla Id:
      9,554
    • Status Whiteboard:

      v3_exclude

      Show
      v3_exclude

      Description

      I'm try to compile artifact as hk2-jar package. If I put the long russian text
      in description section, maven failure to make jar file with exception:

      org.apache.maven.lifecycle.LifecycleExecutionException: Error assembling JAR
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:583)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:499)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:478)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:330)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:291)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:142)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:336)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:129)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:287)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.maven.plugin.MojoExecutionException: Error assembling JAR
      at
      com.sun.enterprise.module.maven.PackageMojo.createArchive(PackageMojo.java:208)
      at com.sun.enterprise.module.maven.PackageMojo.execute(PackageMojo.java:218)
      at
      org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:451)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:558)
      ... 16 more
      Caused by: java.lang.StringIndexOutOfBoundsException: String index out of range: 70
      at java.lang.String.substring(String.java:1934)
      at
      org.codehaus.plexus.archiver.jar.Manifest$Attribute.writeLine(Manifest.java:393)
      at
      org.codehaus.plexus.archiver.jar.Manifest$Attribute.writeValue(Manifest.java:374)
      at
      org.codehaus.plexus.archiver.jar.Manifest$Attribute.write(Manifest.java:344)
      at
      org.codehaus.plexus.archiver.jar.Manifest$Section.write(Manifest.java:595)
      at org.codehaus.plexus.archiver.jar.Manifest.write(Manifest.java:1089)
      at
      org.codehaus.plexus.archiver.jar.JarArchiver.writeManifest(JarArchiver.java:400)
      at
      org.codehaus.plexus.archiver.jar.JarArchiver.initZipOutputStream(JarArchiver.java:339)
      at
      org.codehaus.plexus.archiver.zip.AbstractZipArchiver.createArchiveMain(AbstractZipArchiver.java:327)
      at
      org.codehaus.plexus.archiver.zip.AbstractZipArchiver.createArchive(AbstractZipArchiver.java:229)
      at
      org.apache.maven.archiver.MavenArchiver.createArchive(MavenArchiver.java:332)
      at
      com.sun.enterprise.module.maven.PackageMojo.createArchive(PackageMojo.java:203)
      ... 19 more

        Activity

        janey added a comment -

        Can you attach the pom.xml?

        Not a v3 release stopper.

        janey added a comment -

        have not heard back from the submitter...
        Also just curious... why do you want to add russian text in description section. From the stacktrace, the
        exception is coming from org.codehaus.plexus. It may not be related to hk2-jar.

        Caused by: java.lang.StringIndexOutOfBoundsException: String index out of range: 70
        at java.lang.String.substring(String.java:1934)
        at
        org.codehaus.plexus.archiver.jar.Manifest$Attribute.writeLine(Manifest.java:393)

        Closing this bug.


          People

          • Assignee:
            janey
            Reporter:
            vektor79
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: