glassfish
  1. glassfish
  2. GLASSFISH-9663

upgrade hang when multiple applications are deployed

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: upgrade_tool
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

    • Issuezilla Id:
      9,663

      Description

      Sidebyside upgrade between 9.1_01 and v3 on linux5.0 in cli mode.

      I deployed 10 applications on 9.1_01 b09d. After upgrading to v3, the upgrade
      process hangs after more than 20 minutes wait time.

      1. ls -al /opt/91_01/domains/domain1/applications/j2ee-apps/
        total 56
        drwxr-xr-x 14 root root 4096 Sep 22 07:50 .
        drwxr-xr-x 6 root root 4096 Sep 22 07:23 ..
        drwxr-xr-x 5 root root 4096 Sep 22 07:40 connector-cciApp
        drwxr-xr-x 6 root root 4096 Sep 22 07:42 connector-embedded-cciApp
        drwxr-xr-x 6 root root 4096 Sep 22 07:37 ejb-cmp-cmporderApp
        drwxr-xr-x 6 root root 4096 Sep 22 07:35 ejb-cmp-rosterApp
        drwxr-xr-x 4 root root 4096 Sep 22 07:33 __ejb_container_timer_app
        drwxr-xr-x 5 root root 4096 Sep 22 07:32 ejb-ejb30-hello-sessionApp
        drwxr-xr-x 5 root root 4096 Sep 22 07:28 ejb-mdb-simpleApp
        drwxr-xr-x 5 root root 4096 Sep 22 07:44 ejb-sfsblifecyleApp
        drwxr-xr-x 5 root root 4096 Sep 22 07:25 ejb-stateless-converterApp
        drwxr-xr-x 4 root root 4096 Sep 22 07:25 __JWSappclients
        drwxr-xr-x 4 root root 4096 Sep 22 07:24 MEjbApp
        drwxr-xr-x 5 root root 4096 Sep 22 07:50 sec-ssl-converterApp

      Steps to produce:
      1) pick up from
      /net/koori/onestop/glassfish/9.1_01/promoted/fcs/b09d/bundles/sjsas-9_1_01-fcs-bin-b09d-linux-06_dec_2007.bin
      2) install build
      3) checkout quicklooks tests using instruction at
      http://glassfish.dev.java.net/public/GuidelinesandConventions.html#Quicklook_Tests
      4) need to modify each test build.xml to do everything except undeploy,unsetup
      because we need these applications and its setup to be transferred to v3 server.
      5) execute tests using ant all-pe
      6) stop domain1, derby db
      7) install glassfish v3 nightly build dated 9/22/09 in a different location
      other than 9.1_01 build location
      8) invoke asupgrade in <glassfishv3 install>/bin/asupgrade in cli mode

      1. domains.jar
        3.19 MB
        1xpert
      2. domains.jar
        4.42 MB
        1xpert
      3. server.log
        518 kB
        1xpert

        Issue Links

          Activity

          1xpert added a comment -

          More details on Step 3 of this issue.

          Easy way to checkout V2 quicklooks test:

          1) set variables:
          set CVSROOT to :pserver:<your java.net id>@cvs.dev.java.net:/cvs
          set APS_HOME to point to <quicklooks workspace>/appserv-tests
          set S1AS_HOME to point to appserver or glassfish server
          set JAVA_HOME to point to 1.6.0_14
          set ANT_HOME to point to 1.6.5
          set PATH to point to $ANT_HOME/bin:$JAVA_HOME/bin:$PATH

          2) cvs login
          cvs co -r SJSAS91_FCS_BRANCH glassfish/appserv-tests

          3) cd <workspace directory>/appserv-tests/sqetests and choose to execute the
          following tests.

          connector/cci
          connector/cci-embedded
          ejb/cmp/roster
          ejb/ejb30/hello
          ejb/mdb/simple
          ejb/stateful/passivate
          ejb/stateless/converter
          ejb/security/ssl/converter

          Bobby Bissett added a comment -

          Cannot run the server with the attached domain. There are many warnings in the log when I start up. Were
          there any databases created? If so, these need to be attached as well. I'll try just deploying the individual
          sqe tests to see if that works, but if not we may need to have a simplified test case for this bug. I'd rather
          not spend too much time on this because I think it may be fixed anyway now because of work on issue
          9351.

          Bobby Bissett added a comment -

          Still cannot even run the test case as instructed. Running even one test, sqetests/connector/cci, hangs
          during the test run and I see this error in the v2.1 server log:

          [#|2009-10-02T11:51:05.946-0400|INFO|sun-
          appserver2.1|javax.enterprise.resource.resourceadapter|_ThreadID=18;_ThreadName=p: thread-pool-
          1; w: 6;|org.apache.derby.client.am.SqlException: Java exception: 'SampleExternalMethods:
          java.lang.ClassNotFoundException'.|#]

          Will try again to simply deploy the apps without running the test and do an upgrade, but this is the best
          I can do without further instructions on how to use the sqe tests.

          Bobby Bissett added a comment -

          Works for me – the steps I took are below. I am thinking that the work on issue 9351 fixed this. Here
          my steps for reproducing the issue in case I've missed anything:

          1. In v2.1/glassfish dir, started database and server.

          2. Deploy connector/cci

          hostname% cvs diff build.xml
          Index: build.xml
          ===============================================================
          ====
          RCS file: /cvs/glassfish/appserv-tests/sqetests/connector/cci/build.xml,v
          retrieving revision 1.3
          diff -r1.3 build.xml
          18c18
          < <target name="all" depends="build,setup,deploy,run,undeploy,unsetup"/>

          > <target name="all" depends="build,setup,deploy"/>

          run "ant -emacs all"

          3. Repeat
          hostname% cvs diff build.xml
          Index: build.xml
          ===============================================================
          ====
          RCS file: /cvs/glassfish/appserv-tests/sqetests/connector/cci-embedded/build.xml,v
          retrieving revision 1.3
          diff -r1.3 build.xml
          18c18
          < <target name="all" depends="build,setup,deploy,run,undeploy,unsetup"/>

          > <target name="all" depends="build,setup,deploy"/>

          Server had the following error, but the ant target completed successfully so am continuing:

          [#|2009-10-02T12:21:28.006-0400|WARNING|sun-
          appserver2.1|javax.enterprise.system.stream.err|_ThreadID=15;_ThreadName=httpWorkerThread-
          4848-0;_RequestID=26925415-6c35-41b4-9628-436605c4b6e4;|java.lang.NullPointerException
          at
          com.sun.enterprise.server.ConnectorResourcesLoader.loadEmbeddedRarResources(ConnectorResources
          Loader.java:170)
          at
          com.sun.enterprise.server.ApplicationManager.applicationDeployed(ApplicationManager.java:664)
          at
          com.sun.enterprise.admin.event.AdminEventMulticaster.invokeApplicationDeployEventListener(AdminEv
          entMulticaster.java:959)
          at
          com.sun.enterprise.admin.event.AdminEventMulticaster.handleApplicationDeployEvent(AdminEventMult
          icaster.java:943)
          at
          com.sun.enterprise.admin.event.AdminEventMulticaster.processEvent(AdminEventMulticaster.java:467)
          at
          com.sun.enterprise.admin.event.AdminEventMulticaster.multicastEvent(AdminEventMulticaster.java:182
          )
          at
          com.sun.enterprise.admin.server.core.DeploymentNotificationHelper.multicastEvent(DeploymentNotific
          ationHelper.java:308)
          at
          com.sun.enterprise.deployment.phasing.DeploymentServiceUtils.multicastEvent(DeploymentServiceUtils
          .java:231)
          at
          com.sun.enterprise.deployment.phasing.ServerDeploymentTarget.sendStartEvent(ServerDeploymentTar
          get.java:298)
          at
          com.sun.enterprise.deployment.phasing.ApplicationStartPhase.runPhase(ApplicationStartPhase.java:132
          )
          at
          com.sun.enterprise.deployment.phasing.DeploymentPhase.executePhase(DeploymentPhase.java:108)
          at
          com.sun.enterprise.deployment.phasing.PEDeploymentService.executePhases(PEDeploymentService.java
          :966)
          at
          com.sun.enterprise.deployment.phasing.PEDeploymentService.start(PEDeploymentService.java:609)
          at
          com.sun.enterprise.deployment.phasing.PEDeploymentService.start(PEDeploymentService.java:653)
          at
          com.sun.enterprise.admin.mbeans.ApplicationsConfigMBean.start(ApplicationsConfigMBean.java:773)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at com.sun.enterprise.admin.MBeanHelper.invokeOperationInBean(MBeanHelper.java:381)
          at com.sun.enterprise.admin.MBeanHelper.invokeOperationInBean(MBeanHelper.java:364)
          at com.sun.enterprise.admin.config.BaseConfigMBean.invoke(BaseConfigMBean.java:477)
          at
          com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:836
          )
          at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:761)
          at sun.reflect.GeneratedMethodAccessor12.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at com.sun.enterprise.admin.util.proxy.ProxyClass.invoke(ProxyClass.java:90)
          at $Proxy1.invoke(Unknown Source)
          at
          com.sun.enterprise.admin.server.core.jmx.SunoneInterceptor.invoke(SunoneInterceptor.java:304)
          at com.sun.enterprise.interceptor.DynamicInterceptor.invoke(DynamicInterceptor.java:174)
          at com.sun.enterprise.admin.jmx.remote.server.callers.InvokeCaller.call(InvokeCaller.java:69)
          at
          com.sun.enterprise.admin.jmx.remote.server.MBeanServerRequestHandler.handle(MBeanServerRequest
          Handler.java:155)
          at
          com.sun.enterprise.admin.jmx.remote.server.servlet.RemoteJmxConnectorServlet.processRequest(Remo
          teJmxConnectorServlet.java:122)
          at
          com.sun.enterprise.admin.jmx.remote.server.servlet.RemoteJmxConnectorServlet.doPost(RemoteJmxCo
          nnectorServlet.java:193)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:754)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
          at org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:427)
          at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:315)
          at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:287)
          at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:218)
          at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
          at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
          at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94)
          at
          com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.ja
          va:98)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:222)
          at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
          at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
          at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
          at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1096)
          at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:166)
          at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
          at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
          at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
          at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1096)
          at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:288)
          at
          com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.ja
          va:647)
          at
          com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:5
          79)
          at
          com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:831
          )
          at
          com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.jav
          a:341)
          at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:263)
          at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:214)
          at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:265)
          at com.sun.enterprise.web.connector.grizzly.WorkerThreadImpl.run(WorkerThreadImpl.java:116)

          #]

          [#|2009-10-02T12:21:28.014-0400|WARNING|sun-
          appserver2.1|javax.enterprise.system.tools.admin|_ThreadID=15;_ThreadName=httpWorkerThread-
          4848-0;_RequestID=26925415-6c35-41b4-9628-436605c4b6e4;|ADM5603:Event listener error
          [null]|#]

          [#|2009-10-02T12:21:28.029-0400|WARNING|sun-
          appserver2.1|javax.enterprise.system.tools.admin|_ThreadID=15;_ThreadName=httpWorkerThread-
          4848-0;Error while loading application [connector-embedded-cciApp]. Please refer to the server log
          for more details. ;_RequestID=26925415-6c35-41b4-9628-436605c4b6e4;|ADM1075:Error on
          listening event:[Error while loading application [connector-embedded-cciApp]. Please refer to the
          server log for more details. ]|#]

          4. Repeat

          hostname% cvs diff build.xml
          Index: build.xml
          ===============================================================
          ====
          RCS file: /cvs/glassfish/appserv-tests/sqetests/ejb/cmp/roster/build.xml,v
          retrieving revision 1.1.1.1
          diff -r1.1.1.1 build.xml
          15c15
          < <target name="all" depends="build,setup,deploy,run,undeploy,unsetup"/>

          > <target name="all" depends="build,setup,deploy"/>

          5. Repeat

          hostname% cvs diff build.xml
          Index: build.xml
          ===============================================================
          ====
          RCS file: /cvs/glassfish/appserv-tests/sqetests/ejb/ejb30/hello/session/build.xml,v
          retrieving revision 1.6
          diff -r1.6 build.xml
          17c17
          < <target name="all" depends="build,setup,deploy,run,undeploy,unsetup"/>

          > <target name="all" depends="build,setup,deploy"/>

          (Note: for some reason, this stopped and restarted the server. That should be a separate target!)

          6. Repeat

          hostname% cvs diff build.xml
          Index: build.xml
          ===============================================================
          ====
          RCS file: /cvs/glassfish/appserv-tests/sqetests/ejb/mdb/simple/build.xml,v
          retrieving revision 1.1.1.1
          diff -r1.1.1.1 build.xml
          15c15
          < <target name="all" depends="build,setup,deploy,run,undeploy,unsetup"/>

          > <target name="all" depends="build,setup,deploy"/>

          7. Repeat

          hostname% !cvs
          cvs diff build.xml
          Index: build.xml
          ===============================================================
          ====
          RCS file: /cvs/glassfish/appserv-tests/sqetests/ejb/stateful/passivate/build.xml,v
          retrieving revision 1.1.1.1
          diff -r1.1.1.1 build.xml
          15c15
          < <target name="all" depends="build,setup,deploy,run,undeploy,unsetup"/>

          > <target name="all" depends="build,setup,deploy"/>

          8. Repeat

          hostname% cvs diff build.xml
          Index: build.xml
          ===============================================================
          ====
          RCS file: /cvs/glassfish/appserv-tests/sqetests/ejb/stateless/converter/build.xml,v
          retrieving revision 1.3
          diff -r1.3 build.xml
          16c16
          < <target name="all" depends="clean,build,setup,deploy,run,undeploy,unsetup"/>

          > <target name="all" depends="clean,build,setup,deploy"/>

          9. Repeat

          hostname% cvs diff build.xml
          Index: build.xml
          ===============================================================
          ====
          RCS file: /cvs/glassfish/appserv-tests/sqetests/security/ssl/converter/build.xml,v
          retrieving revision 1.6
          diff -r1.6 build.xml
          16c16
          < <target name="all" depends="build,deploy,run,undeploy"/>

          > <target name="all" depends="build,deploy"/>

          10. Verify that they're deployed:

          hostname% ~/servers/gfv2.1/glassfish/bin/asadmin list-components
          cciblackbox-tx <connector-module>
          connector-cciApp <j2ee-application>
          connector-embedded-cciApp <j2ee-application>
          ejb-cmp-rosterApp <j2ee-application>
          ejb-ejb30-hello-sessionApp <j2ee-application>
          ejb-mdb-simpleApp <j2ee-application>
          ejb-sfsblifecyleApp <j2ee-application>
          ejb-stateless-converterApp <j2ee-application>
          sec-ssl-converterApp <j2ee-application>
          Command list-components executed successfully.

          11. Shut down v2 server

          12. Run the upgrade. Upgrade did not hang. There were some errors in the server log about a corba
          issue, but this is unrelated to the upgrade (I see the same error simply starting the domain with revision
          32174 of the workspace).

          Bobby Bissett added a comment -

          Adding vella to cc list to keep up to date on upgrade status.


            People

            • Assignee:
              Bobby Bissett
              Reporter:
              1xpert
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: