glassfish
  1. glassfish
  2. GLASSFISH-9825

DXAR:start():Warning:Received diff Xid for open txnId:switching transactionId

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: v2.1
    • Fix Version/s: V3
    • Component/s: jms
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Linux

    • Issuezilla Id:
      9,825

      Description

      This error appears in the Glassfish log:

      [#|2009-09-29T17:33:31.127+0200|INFO|sun-appserver2.1|javax.enterprise.system.stream.out|_ThreadID=18;_ThreadName=p:
      thread-pool-1; w: 5;|DXAR:start():Warning:Received diff Xid for open
      txnId:switching transactionId:
      DXAR
      Xid=616C636F722C7365727665722C50333730302C010B000000BB566F06616C636F722C7365727665722C5033373030
      DXAR TXid=1776991138030900224
      got Xid=null
      got TXid=1776991138030909184|#]

      Afterwards, this error shows up:
      [#|2009-09-29T17:33:31.134+0200|WARNING|sun-appserver2.1|javax.enterprise.system.core.transaction|_ThreadID=19;_ThreadName=p:
      thread-pool-1; w: 6;java.lang.RuntimeException:
      javax.transaction.xa.XAException;prepare;_RequestID=f0001a51-e07e-4a21-91de-e1de0877be9c;|JTS5031:
      Exception [java.lang.RuntimeException: javax.transaction.xa.XAException] on
      Resource [prepare] operation.|#]

      [#|2009-09-29T17:33:31.136+0200|WARNING|sun-appserver2.1|javax.enterprise.system.core.transaction|_ThreadID=19;_ThreadName=p:
      thread-pool-1; w: 6;_RequestID=f0001a51-e07e-4a21-91de-e1de0877be9c;|JTS5068:
      Unexpected error occurred in rollback
      java.lang.NullPointerException
      at
      com.sun.messaging.jmq.jmsserver.data.handlers.TransactionHandler.doRollback(TransactionHandler.java:1200)
      at
      com.sun.messaging.jmq.jmsserver.data.protocol.ProtocolImpl.rollbackTransaction(ProtocolImpl.java:683)
      at
      com.sun.messaging.jmq.jmsserver.service.imq.IMQDirectService.rollbackTransaction(IMQDirectService.java:1805)
      at com.sun.messaging.jms.ra.DirectXAResource.rollback(DirectXAResource.java:533)
      at com.sun.jts.jta.TransactionState.rollback(TransactionState.java:194)
      at com.sun.jts.jtsxa.OTSResourceImpl.rollback(OTSResourceImpl.java:311)
      at
      com.sun.jts.CosTransactions.RegisteredResources.distributeRollback(RegisteredResources.java:1049)
      at com.sun.jts.CosTransactions.TopCoordinator.rollback(TopCoordinator.java:2297)
      at com.sun.jts.CosTransactions.CoordinatorTerm.commit(CoordinatorTerm.java:410)
      at com.sun.jts.CosTransactions.TerminatorImpl.commit(TerminatorImpl.java:250)
      at com.sun.jts.CosTransactions.CurrentImpl.commit(CurrentImpl.java:623)
      at
      com.sun.jts.jta.TransactionManagerImpl.commit(TransactionManagerImpl.java:309)
      at
      com.sun.enterprise.distributedtx.J2EETransactionManagerImpl.commit(J2EETransactionManagerImpl.java:1003)
      at
      com.sun.enterprise.distributedtx.J2EETransactionManagerOpt.commit(J2EETransactionManagerOpt.java:398)
      at com.sun.ejb.containers.BaseContainer.completeNewTx(BaseContainer.java:3817)
      at com.sun.ejb.containers.BaseContainer.postInvokeTx(BaseContainer.java:3596)
      at
      com.sun.ejb.containers.MessageBeanContainer.afterMessageDeliveryInternal(MessageBeanContainer.java:1226)
      at
      com.sun.ejb.containers.MessageBeanContainer.afterMessageDelivery(MessageBeanContainer.java:1197)
      at
      com.sun.ejb.containers.MessageBeanListenerImpl.afterMessageDelivery(MessageBeanListenerImpl.java:79)
      at
      com.sun.enterprise.connectors.inflow.MessageEndpointInvocationHandler.invoke(MessageEndpointInvocationHandler.java:139)
      at $Proxy73.afterDelivery(Unknown Source)
      at com.sun.messaging.jms.ra.OnMessageRunner.run(OnMessageRunner.java:324)
      at com.sun.enterprise.connectors.work.OneWork.doWork(OneWork.java:76)
      at
      com.sun.corba.ee.impl.orbutil.threadpool.ThreadPoolImpl$WorkerThread.run(ThreadPoolImpl.java:555)

      #]

      This can be reproduced by the attached NB project, were two MDB process messages
      and route them using a given MessageRouterBean.

        Activity

        Satish Kumar added a comment -
            • Issue 9824 has been marked as a duplicate of this issue. ***
        Satish Kumar added a comment -

        Requesting the MQ team to investigate since the stacktrace points to the MQ
        code...

        Satish Kumar added a comment -
            • Issue 9824 has been marked as a duplicate of this issue. ***
        Satish Kumar added a comment -

        Requesting the MQ team to investigate since the stacktrace points to the MQ
        code...

        Satish Kumar added a comment -

        Requesting the MQ team to investigate since the stacktrace points to the MQ
        code...

        Satish Kumar added a comment -

        This issue seems exactly identical to 9824. Hence marking this as a duplicate

            • This issue has been marked as a duplicate of 9824 ***

          People

          • Assignee:
            Satish Kumar
            Reporter:
            jthoennes
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: