glassfish
  1. glassfish
  2. GLASSFISH-9851

SQLSystaxErrorException: Table/View does not exist

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: upgrade_tool
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      9,851

      Description

      Sidebyside upgrade from v3 prelude to v3 nightly build 9/29/09 on winxp using
      JPA test

      Steps to reproduce:
      1) install v3 prelude, start domain1, start derby
      2) checkout v3 prelude quicklook test as followed:

      need to have subversion svn-win32-1.5.4.zip
      need to set environment variables JAVA_HOME, ANT_HOME, S1AS_HOME (glassfish
      location), PATH to point to ANT_HOME\bin, JAVA_HOME\bin,SVN_HOME\bin

      svn co https://svn.dev.java.net/svn/glassfish-svn/tags/glassfish-3.0-Prelude-
      b28c/tests
      cd <workspace>\tests\quicklook\persistence\jpainjectemf
      ant -Dglassfish.home=%S1AS_HOME% build deploy runtest
      open ij in <v3 installation>/javadb/bin
      at the prompt ij> , enter command
      connect 'jdbc:derby://localhost:1527/sun-appserv-
      samples;create=true;user=app;password=app';
      at the prompt ij>, enter command
      delete from Department;
      delete from Employee;

      3) stop domain, stop derby

      4) install v3 build 9/29/09 from location below:
      http://javaweb.sfbay.sun.com/java/re/glassfish/v3/nightly/bundles/

      latest-glassfish.zip 29-Sep-2009 03:03 73M

      5) start asupgrade from <v3 installation>/bin

      6) cd <workspace>\tests\quicklook\persistence\jspinjectemf

      run "ant -Dglassfish.home=<v3 installation> runtest"

        Activity

        Bobby Bissett added a comment -

        From these instructions, you never restarted the database (or the v3 app server), so the tables won't be
        found by the application. Can you confirm these steps and make sure the database is running – the same
        one that was running when you deployed the apps into the original server?

        Bobby Bissett added a comment -
            • Issue 9852 has been marked as a duplicate of this issue. ***
        Bobby Bissett added a comment -

        These steps are unusual – it would be good to include the explanation that the data in the tables
        must be manually dropped before repeating the test. Note that I can't delete the Department data
        before Employee. Instead I have to use: "delete from Employee; delete from Department;"

        As long as I leave the database running, I can perform the upgrade and run the test successfully
        against server. I think the issue you're seeing is because you shut down the database that had the
        tables in it.

        — begin —
        hostname% ant -emacs -Dglassfish.home=/Users/bobby/servers/glassfishv3/glassfish runtest
        Buildfile: build.xml

        runtest:

        runtest-impl:

        compile-tests:
        compiling test client to ../..//classes/test
        Compiling 1 source file to /Users/bobby/work/ws/v3quicklook_tests/tests/quicklook/classes/test
        Note:
        /Users/bobby/work/ws/v3quicklook_tests/tests/quicklook/persistence/jpainjectemf/src/test/JpaInject
        EMFTestNG.java uses or overrides a deprecated API.
        Note: Recompile with -Xlint:deprecation for details.

        checkTestNGXML:

        runtest-impl-class:
        =============Starting TestNG test at ../..//classes/test ============
        [Parser] Running:
        jpainjectemf

        url=http://localhost:8080/jpainjectemf/jpa?testcase=llinit
        url=http://localhost:8080/jpainjectemf/jpa?testcase=llquery

        ===============================================
        jpainjectemf
        Total tests run: 2, Failures: 0, Skips: 0
        ===============================================

        checkTestNGXML:

        runtest-impl-xml:

        BUILD SUCCESSFUL
        Total time: 7 seconds
        — out —


          People

          • Assignee:
            Bobby Bissett
            Reporter:
            1xpert
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: