glassfish
  1. glassfish
  2. GLASSFISH-9852

SQLSystaxErrorException: Table/View does not exist

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: upgrade_tool
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      9,852

      Description

      Sidebyside upgrade from v3 prelude to v3 nightly build 9/29/09 on winxp using
      JPA test

      Could access url http://localhost:8080/jpainjectemf/jpa?testcase=llinit

      Steps to reproduce:
      1) install v3 prelude, start domain1, start derby
      2) checkout v3 prelude quicklook test as followed:

      need to have subversion svn-win32-1.5.4.zip
      need to set environment variables JAVA_HOME, ANT_HOME, S1AS_HOME (glassfish
      location), PATH to point to ANT_HOME\bin, JAVA_HOME\bin,SVN_HOME\bin

      svn co https://svn.dev.java.net/svn/glassfish-svn/tags/glassfish-3.0-Prelude-
      b28c/tests
      cd <workspace>\tests\quicklook\persistence\jpainjectemf
      ant -Dglassfish.home=%S1AS_HOME% build deploy runtest
      open ij in <v3 installation>/javadb/bin
      at the prompt ij> , enter command
      connect 'jdbc:derby://localhost:1527/sun-appserv-
      samples;create=true;user=app;password=app';
      at the prompt ij>, enter command
      delete from Department;
      delete from Employee;

      3) stop domain, stop derby

      4) install v3 build 9/29/09 from location below:
      http://javaweb.sfbay.sun.com/java/re/glassfish/v3/nightly/bundles/

      latest-glassfish.zip 29-Sep-2009 03:03 73M

      5) start asupgrade from <v3 installation>/bin

      6) cd <workspace>\tests\quicklook\persistence\jspinjectemf

      run "ant -Dglassfish.home=<v3 installation> runtest"

      1. server.log
        16 kB
        1xpert
      2. server.log
        16 kB
        1xpert

        Activity

        1xpert added a comment -

        Created an attachment (id=3356)
        server.log

        1xpert added a comment -

        Created an attachment (id=3357)
        server.log

        Bobby Bissett added a comment -

        From these instructions, you never restarted the database (or the v3 app server), so the tables won't be
        found by the application. Can you confirm these steps and make sure the database is running – the same
        one that was running when you deployed the apps into the original server?

        1xpert added a comment -

        Closed. duplicate of issue 9851.
        Same issue was entered in the system twice due to recent outage problem.

        Bobby Bissett added a comment -

        Marking resolved per Nga's comment.

            • This issue has been marked as a duplicate of 9851 ***
        Bobby Bissett added a comment -

        Closing since this one wasn't meant to be filed. Per Nga's request.


          People

          • Assignee:
            Bobby Bissett
            Reporter:
            1xpert
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: