Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: eclipse
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      146

      Description

      When I open the servers view, my previous setting appear in the list. Theses
      setting were created by another Eclipse with GF plugin, not the bundle.

      when the servers view open, I see them and when I click on them.. I obtain this
      message when I clicked on my previous GFv2 setup.

        Activity

        raccah added a comment -

        I can reproduce even with the fix for 143, so reopening.

        ludo added a comment -

        The key area of this bug has been fixed in 143.
        Maybe the new issue is around mix/match of workspaces done by external eclipse
        installs and the bundle.
        Rochelle will test more. Moving to p4 so it cannot be seen as a shown stopper
        for te bundle v1.0. Will be fixed in v1.0.1.
        If you can reproduce, it would be interesting to not what happens when you
        restart the IDE after this. I think the error would be gone anyway.
        Or maybe the server definition was pointing to a non existent anymore server domain?

        raccah added a comment -

        Yes, I can verify that the problem was indeed a previously registered server
        with an incorrect (non-existent) domain dir. In this case the fix is a better
        error message.

        raccah added a comment -

        Fixed - will be in 1.0.24.

        raccah added a comment -

        Note that it is not straightforward to bring up an alert dialog (timing,
        multiple instances of server/behavior and calls to initialize). What I've done is:

        • error message in the bottom of the editor when you open it
        • exception in the log in port available
        • you will see same kind of dialog on run server as before, but this time error
          message will be nicer
        • no exceptions on opening the menus

          People

          • Assignee:
            raccah
            Reporter:
            survivant
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: