glassfishplugins
  1. glassfishplugins
  2. GLASSFISHPLUGINS-370

Glassfish 4 doesn't start in debug mode (Kepler)

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Blocker Blocker
    • Resolution: Unresolved
    • Affects Version/s: not determined
    • Fix Version/s: None
    • Component/s: eclipse
    • Labels:
      None
    • Environment:

      Win 7 64b, JDK 1.7.0_21, Java EE Kepler RC3, GlassFish Tools 6.0.2.201306071627

      Description

      Installed GlassFish Tools 6.0.2.201306071627 on Java EE Kepler RC3 on win7 64b, I can start the GlassFish 4.0 in normal mode, but when trying in debug mode (with JDK 1.7.0_21), startup is stuck:
      Progress Bar : Starting GlassFish 4.0 at localhost | Launching delegate... Stuck at 69%

      See attached threaddump.

        Issue Links

          Activity

          Hide
          velio added a comment -

          Hi piotrik,
          Seems it works for me too.
          I had running in debug mode resolved by experienced some troubles sometimes on starting Glassfish - blocking on 69%.
          So far, couple of days as I had the update installed it just works fine.
          Thanks

          Show
          velio added a comment - Hi piotrik, Seems it works for me too. I had running in debug mode resolved by experienced some troubles sometimes on starting Glassfish - blocking on 69%. So far, couple of days as I had the update installed it just works fine. Thanks
          Hide
          kkurt added a comment -

          I am still getting error (in both debug and normal starting mode):

          java.util.concurrent.TimeoutException
          at java.util.concurrent.FutureTask$Sync.innerGet(Unknown Source)
          at java.util.concurrent.FutureTask.get(Unknown Source)
          at oracle.eclipse.tools.glassfish.GlassfishGenericServerBehaviour.launchServer(GlassfishGenericServerBehaviour.java:202)
          at oracle.eclipse.tools.glassfish.GlassfishServerLaunchDelegate.startDASAndTarget(GlassfishServerLaunchDelegate.java:206)
          at oracle.eclipse.tools.glassfish.GlassfishServerLaunchDelegate.launch(GlassfishServerLaunchDelegate.java:110)
          at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:858)
          at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:707)
          at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:700)
          at org.eclipse.wst.server.core.internal.Server.startImpl2(Server.java:3537)
          at org.eclipse.wst.server.core.internal.Server.startImpl(Server.java:3473)
          at org.eclipse.wst.server.core.internal.Server$StartJob.run(Server.java:367)
          at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

          Show
          kkurt added a comment - I am still getting error (in both debug and normal starting mode): java.util.concurrent.TimeoutException at java.util.concurrent.FutureTask$Sync.innerGet(Unknown Source) at java.util.concurrent.FutureTask.get(Unknown Source) at oracle.eclipse.tools.glassfish.GlassfishGenericServerBehaviour.launchServer(GlassfishGenericServerBehaviour.java:202) at oracle.eclipse.tools.glassfish.GlassfishServerLaunchDelegate.startDASAndTarget(GlassfishServerLaunchDelegate.java:206) at oracle.eclipse.tools.glassfish.GlassfishServerLaunchDelegate.launch(GlassfishServerLaunchDelegate.java:110) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:858) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:707) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:700) at org.eclipse.wst.server.core.internal.Server.startImpl2(Server.java:3537) at org.eclipse.wst.server.core.internal.Server.startImpl(Server.java:3473) at org.eclipse.wst.server.core.internal.Server$StartJob.run(Server.java:367) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
          Hide
          piotrik added a comment -

          hi kkurt, are you using kepler or juno? only kepler was updated with the fix.

          Show
          piotrik added a comment - hi kkurt, are you using kepler or juno? only kepler was updated with the fix.
          Hide
          kkurt added a comment -

          Hi piotrik, i am using kepler.

          Show
          kkurt added a comment - Hi piotrik, i am using kepler.
          Hide
          dgisbert added a comment - - edited

          Hi.

          After more than one month an a half using the last version of Glassfish Tools for Eclipse (at the moment I am writing this I have version 6.2.1.201309260928 installed on my Eclipse Kepler installation) I haven't had again the same problem. In my opinion it seems that the problem of randomly hanging issues is solved, but because of its random nature I can't assure that they will appear again suddenly at any moment.

          By the way, it seems that the external references above for this issue has been spammed.

          Show
          dgisbert added a comment - - edited Hi. After more than one month an a half using the last version of Glassfish Tools for Eclipse (at the moment I am writing this I have version 6.2.1.201309260928 installed on my Eclipse Kepler installation) I haven't had again the same problem. In my opinion it seems that the problem of randomly hanging issues is solved, but because of its random nature I can't assure that they will appear again suddenly at any moment. By the way, it seems that the external references above for this issue has been spammed.

            People

            • Assignee:
              Unassigned
              Reporter:
              fbricon
            • Votes:
              14 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

              • Created:
                Updated: