glassfish-samples
  1. glassfish-samples
  2. GLASSFISH_SAMPLES-22

absolute-...fragments-war requires resolve references manually

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: javaee6
    • Fix Version/s: milestone 1
    • Component/s: web
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Macintosh

    • Issuezilla Id:
      22

      Description

      -This problem only happens on Mac OSX
      -If select to open the the project with option "Open Required Projects" the
      "References Problem" dialog wil appears.

      Steps To Reproduce:
      1. Install NB 6.8 Nightly build (11/04/2009)
      2. Install SDK6-b27 (b71) build
      3. Start the IDE -> open the web absolute-ordering-web-fragments-war project
      Note:
      In order to select the "Open Required Projects" option, you might need to
      open the "servletcontainerinitilizer-war" first

      1. messages.log
        116 kB
        davisn
      2. server.log
        11 kB
        davisn
      3. server.log
        21 kB
        davisn
      1. ResolveReferences.png
        27 kB

        Activity

        davisn added a comment -

        Created an attachment (id=3)
        IDE log file

        davisn added a comment -

        Created an attachment (id=4)
        server.log file

        davisn added a comment -

        I tried to replicate the ide log file to attach to the bug, and this time I got
        an exception to open the absolute-...fragments-war file on my WindowXP machine.
        Below is the full steps I did before getting into the exception.
        -Open web/servlet/mutiple-war and run
        -Open web/servlet/jsp-resource-in-bundled-jar-war and run
        -Open web/jsp/basic-ajax and run
        -Open web/jsp/basic-ezcomp and run
        -Open web/servlet/absolute-ordering-web-fragment-war

        ide and new server log files attached

        vince kraemer added a comment -

        It looks like you forgot the ant output.... oh well.

        vince kraemer added a comment -

        I could not reproduce this issue... though I have a build from web-main... which is about 6 days ahead
        of the repo that is used for the nightly build.

        Compare the dates on stuff here: http://hg.netbeans.org/web-main and http://hg.netbeans.org/main-
        golden

        The change that should address the original issue that Davis reported should be
        http://hg.netbeans.org/web-main/rev/d1f1271297b2

        Davis: you should be able to unzip the bits from this build to verify the fix...
        http://bertram.netbeans.org/hudson/job/javaee/ – pick any recent 'blue' OR
        http://bertram.netbeans.org/hudson/job/web-main/ – pick any recent 'blue' build


          People

          • Assignee:
            vince kraemer
            Reporter:
            davisn
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: