grizzly
  1. grizzly
  2. GRIZZLY-1167

Grizzly 1.0.42 fails with ExceptionInInitializerError when starting SelectorThread

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.42
    • Fix Version/s: 1.0.43
    • Component/s: http
    • Labels:
      None

      Description

      Problem:
      --------
      Grizzly 1.0.42 bundles or uses org.apache.tomcat.util.http.Parameters
      but did not attach org.apache.tomcat.util.http.LocalStrings
      resource.

      Log


      [#|2012-01-01T19:20:13.209+0800|WARNING|sun-appserver2.1|javax.enterprise.system
      .stream.err|_ThreadID=15;_ThreadName=SelectorThread-6880;_RequestID=8ebea810-589
      8-45f6-aa1a-cf58c27aa77f;|Exception in thread "SelectorThread-6880" |#]

      [#|2012-01-01T19:20:13.220+0800|WARNING|sun-appserver2.1|javax.enterprise.system
      .stream.err|_ThreadID=15;_ThreadName=SelectorThread-6880;_RequestID=8ebea810-589
      8-45f6-aa1a-cf58c27aa77f;|java.lang.ExceptionInInitializerError
      at org.apache.coyote.Request.<init>(Request.java:186)
      at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.initial
      ize(DefaultProcessorTask.java:429)
      at com.sun.enterprise.web.connector.grizzly.SelectorThread.rampUpProcess
      orTask(SelectorThread.java:1161)
      at com.sun.enterprise.web.connector.grizzly.SelectorThread.startEndpoint
      (SelectorThread.java:1293)
      at com.sun.enterprise.web.connector.grizzly.SelectorThread.run(SelectorT
      hread.java:1275)
      Caused by: java.util.MissingResourceException: Can't find bundle for base name o
      rg.apache.tomcat.util.http.LocalStrings, locale en_US
      ...
      at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1260)
      at java.util.ResourceBundle.getBundle(ResourceBundle.java:787)
      at org.apache.tomcat.util.res.StringManager.<init>(StringManager.java:11
      7)
      at org.apache.tomcat.util.res.StringManager.<init>(StringManager.java:10
      9)
      at org.apache.tomcat.util.res.StringManager.getManager(StringManager.jav
      a:288)
      at org.apache.tomcat.util.http.Parameters.<clinit>(Parameters.java:85)
      ... 5 more

      #]

      Alternatively the version should not
      084
      085 protected static final StringManager sm =
      086 StringManager.getManager("org.apache.tomcat.util.http"); <--

        Activity

        Ryan Lubke added a comment -

        Thanks for the report. Could you please try the attached jar and verify the issue is resolved in your environment?

        gfuser9999 added a comment -

        Status: -OK, the jar now works and starts fine.

        Logs showing startup fine
        -------------------------
        [#|2012-01-05T22:44:36.524-0800|INFO|sun-appserver2.1.1|javax.enterprise.system.container.web|_ThreadID=17;_ThreadName=SelectorThread-6869;|
        Grizzly 1.0.43-SNAPSHOT running on SunOS-5.10 under JDK version: 1.6.0_29-Sun Microsystems Inc.
        port: 6869
        socket-tcp-no-delay-enabled: true
        socket-keep-alive-enabled: false
        socket-linger: -1
        socket-oob-inline-enabled: false
        default-write-timeout-millis: 30000
        maxThreads: 5
        ByteBuffer size: 4096
        useDirectByteBuffer: 8192
        maxKeepAliveRequests: 250
        keepAliveTimeoutInSeconds: 30
        Static File Cache enabled: true
        Pipeline : com.sun.enterprise.web.connector.grizzly.LinkedListPipeline
        Round Robin Selector Algorithm enabled: false
        Round Robin Selector pool size: 1
        Asynchronous Request Processing enabled: false|#]

        Ryan Lubke added a comment -

        Thanks for confirming resolution. We'll do a release asap.


          People

          • Assignee:
            Ryan Lubke
            Reporter:
            gfuser9999
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: