hk2
  1. hk2
  2. HK2-74

Support @Proxiable on a binding/contract rather than just on a whole scope.

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.1.*
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Currently only a whole scope can be marked proxiable. It would be practical to support proxiability on a binding/descriptor level so that a single scope instance can contain proxiable as well as non-proxiable bindings.

      Programmatic API should also be updated to support this (IOW, it should be possible to "attach" the @Proxiable annotation to a contract class or interface programmatically using the binding API).

        Activity

        tlcksnyder added a comment -

        duplicate of HK2-75


          People

          • Assignee:
            jwells
            Reporter:
            Marek Potociar
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: