hk2
  1. hk2
  2. HK2-91

Proxy creates subclass even if the proxy is for an interface

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.1.*
    • Fix Version/s: 2.1.*
    • Component/s: None
    • Labels:
      None

      Description

      Today when using the @Proxiable scope or using individual proxies, the system will generate the subclass in order to form the proxy, even if the thing being proxied is an interface. I think this could be vastly improved by noticing that it is an interface being proxied and switching over to the jdk dynamic proxy, rather than using the cglib class proxying.

        Activity

        jwells added a comment -

        Duplicate of HK2-87


          People

          • Assignee:
            jwells
            Reporter:
            jwells
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: