Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 1.1
    • Fix Version/s: milestone 1
    • Component/s: implementation
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      175

      Description

      Run the attached testcase. When J2KImageReadParam.setResolution(-1) is used, the
      image renders blurry. When J2KImageReadParam.setResolution(5) is used it renders
      sharp.

      I expecting the image to render sharp by default.

      This bug report is being discussed at
      http://forums.java.net/jive/thread.jspa?threadID=43179&tstart=0

        Activity

        Hide
        cowwoc added a comment -

        Created an attachment (id=135)
        The testcase

        Show
        cowwoc added a comment - Created an attachment (id=135) The testcase
        Hide
        bokken added a comment -

        From what I can tell, this issue only exists in the native j2k codec. It does not occur when using the pure java implementation.

        I have attached another sample object where I am seeing this issue.

        Show
        bokken added a comment - From what I can tell, this issue only exists in the native j2k codec. It does not occur when using the pure java implementation. I have attached another sample object where I am seeing this issue.
        Hide
        bokken added a comment -

        I have observed this issue for both lossless and lossy compression.

        Show
        bokken added a comment - I have observed this issue for both lossless and lossy compression.

          People

          • Assignee:
            bpb
            Reporter:
            cowwoc
          • Votes:
            2 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated: