Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: www
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      16

      Description

      Most of the source in CVS contains the wrong license. The project is documented
      as using the ASL 2.0, but contains the following:

      /*

      • Japex ver. 0.1 software ("Software")
        *
      • Copyright, 2004-2005 Sun Microsystems, Inc. All Rights Reserved.
        *
      • This Software is distributed under the following terms:
        *
      • Redistribution and use in source and binary forms, with or without
      • modification, is permitted provided that the following conditions are met:
        *
      • Redistributions of source code must retain the above copyright notice,
      • this list of conditions and the following disclaimer.
        *
      • Redistribution in binary form must reproduce the above copyright notice,
      • this list of conditions and the following disclaimer in the
      • documentation and/or other materials provided with the distribution.
        *
      • Neither the name of Sun Microsystems, Inc., 'Java', 'Java'-based names,
      • nor the names of contributors may be used to endorse or promote products
      • derived from this Software without specific prior written permission.
        *
      • The Software is provided "AS IS," without a warranty of any kind. ALL
      • EXPRESS OR IMPLIED CONDITIONS, REPRESENTATIONS AND WARRANTIES, INCLUDING
      • ANY IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
      • PURPOSE OR NON-INFRINGEMENT, ARE HEREBY EXCLUDED. SUN AND ITS LICENSORS
      • SHALL NOT BE LIABLE FOR ANY DAMAGES OR LIABILITIES SUFFERED BY LICENSEE
      • AS A RESULT OF OR RELATING TO USE, MODIFICATION OR DISTRIBUTION OF THE
      • SOFTWARE OR ITS DERIVATIVES. IN NO EVENT WILL SUN OR ITS LICENSORS BE
      • LIABLE FOR ANY LOST REVENUE, PROFIT OR DATA, OR FOR DIRECT, INDIRECT,
      • SPECIAL, CONSEQUENTIAL, INCIDENTAL OR PUNITIVE DAMAGES, HOWEVER CAUSED
      • AND REGARDLESS OF THE THEORY OF LIABILITY, ARISING OUT OF THE USE OF OR
      • INABILITY TO USE SOFTWARE, EVEN IF SUN HAS BEEN ADVISED OF THE
      • POSSIBILITY OF SUCH DAMAGES.
        *
      • You acknowledge that the Software is not designed, licensed or intended
      • for use in the design, construction, operation or maintenance of any
      • nuclear facility.
        */

        Activity

        Santiago Pericas-Geertsen added a comment -

        Long overdue, but fixed now. ASL 2.0 and an updated copyright should be in all source files.


          People

          • Assignee:
            japex-issues
            Reporter:
            crahen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: