japex
  1. japex
  2. JAPEX-22

Japex Error During Generating reports

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: engine
    • Labels:
      None
    • Environment:

      Operating System: AIX
      Platform: Other

    • Issuezilla Id:
      22

      Description

      Hi..
      I have a problem.

      I use Japex with Hudson. This works well in window XP.
      but My company use AIX for developer server.
      so I installed Hudson, Japex, Ant,, etc.

      But Japex isn't work
      because ..
      -----------------------------------------------------------------------
      [java] 304.723,aritmean,304.723,geommean,304.723,harmmean,304.723
      [java] Generating reports ...
      [java]
      file:/usr/Weblogic/dev_server/Hudson/home/jobs/Spring/workspace/trunk/reports/20
      08_04_08_17_44/report.xml
      [java] (Location of error unknown)org.xml.sax.SAXException: Can not
      resolve namespace prefix: xi
      [java]
      file:/usr/Weblogic/dev_server/Hudson/home/jobs/Spring/workspace/trunk/reports/20
      08_04_08_17_44/report.html
      [java] Exception in thread "main" java.lang.NullPointerException
      [java] at com.sun.japex.Japex.run(Japex.java:229)
      [java] at com.sun.japex.Japex.main(Japex.java:127)
      [java] Java Result: 1
      ---------------------------------------------------------------------------

      I have no idea and I test same application on window and Aix.
      but problem is occurred on AIX.

      Do you have any idea ?
      I need your help...

      Appender
      AIX 5.3 , JDK 1.5.0 , Hudson 1.200, Japex 1.1

        Activity

        snolbu2 added a comment -

        Thanks !! Thanks for your solution
        It works!!
        I use your solution that Japex.jar is removed 'xi' namespace in report.xsl.
        I appreciate your help.

        I'm worried that other problem is occurred removing 'xi'.
        and I manage Japex.jar without 'xi' namespace.

        Would you fix this problem ?

        anyway Thanks for your help
        Have a nice day.

        snolbu2 added a comment -

        Thanks !! Thanks for your solution
        It works!!
        I use your solution that Japex.jar is removed 'xi' namespace in report.xsl.
        I appreciate your help.

        I'm worried that other problem is occurred removing 'xi'.
        and I manage Japex.jar without 'xi' namespace.

        Would you fix this problem ?

        anyway Thanks for your help
        Have a nice day.

        snolbu2 added a comment -

        Hi, I have another problem.
        I set Japex in Hudson.
        First time is good, but Second is Out of work
        [Configuration]
        Japex report files : trunk/reports/*/report.xml

        [Error Log]
        ----------------------------------------------------------------------------
        stressTest:
        [java] Reading configuration
        file '/usr/Weblogic/dev_server/Hudson/home/jobs/WAF/workspace/trunk/japexconfig.
        xml' ...
        [java] Estimated warmup time + run time is 3 seconds
        [java] JUnitDriver using 1 thread(s) on 4 cpu(s)
        [java] Run 1: TestDept,....
        [java] Time: 1.997
        [java]
        [java] OK (4 tests)
        [java]
        [java] ....
        [java] Time: 0.144
        [java]
        [java] OK (4 tests)
        [java]
        [java] ....
        [java] Time: 0.12
        [java]
        [java] OK (4 tests)
        [java]
        [java] ....
        [java] Time: 0.121
        [java]
        [java] OK (4 tests)
        [java]
        [java] ....
        [java] Time: 0.1
        [java]
        [java] OK (4 tests)
        [java]
        [java] ....
        [java] Time: 0.099
        [java]
        [java] OK (4 tests)
        [java]
        [java] ....
        [java] Time: 0.114
        [java]
        [java] OK (4 tests)
        [java]
        [java] ....
        [java] Time: 0.107
        [java]
        [java] OK (4 tests)
        [java]
        [java] ....
        [java] Time: 0.093
        [java]
        [java] OK (4 tests)
        [java]
        [java] ....
        [java] Time: 0.164
        [java]
        [java] OK (4 tests)
        [java]
        [java] 307.005,aritmean,307.005,geommean,307.005,harmmean,307.005
        [java] Generating reports ...
        [java] file:/usr/Weblogic/report/waf/reports/2008_04_11_20_59/report.xml
        [java] file:/usr/Weblogic/report/waf/reports/2008_04_11_20_59/report.html
        [mkdir] Created
        dir: /usr/Weblogic/dev_server/Hudson/home/jobs/WAF/workspace/trunk/reports
        [copy] Copying 24 files
        to /usr/Weblogic/dev_server/Hudson/home/jobs/WAF/workspace/trunk/reports

        BUILD SUCCESSFUL
        Total time: 3 minutes 19 seconds
        Recording test results
        Recording japex reports trunk/reports/*/report.xml
        /usr/Weblogic/dev_server/Hudson/home/jobs/WAF/builds/2008-04-11_20-54-
        57/japex/trunk/reports/2008_04_11_20_41/report.xml
        FATAL: null
        java.lang.NullPointerException
        at com.sun.japex.RegressionDetector.generateXmlReport
        (RegressionDetector.java:160)
        at hudson.plugins.japex.JapexPublisher.perform(JapexPublisher.java:140)
        at hudson.tasks.BuildStepCompatibilityLayer.perform
        (BuildStepCompatibilityLayer.java:33)
        at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep
        (AbstractBuild.java:302)
        at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep
        (AbstractBuild.java:290)
        at hudson.model.Build$RunnerImpl.post2(Build.java:134)
        at hudson.model.AbstractBuild$AbstractRunner.post
        (AbstractBuild.java:275)
        at hudson.model.Run.run(Run.java:767)
        at hudson.model.Build.run(Build.java:101)
        at hudson.model.ResourceController.execute(ResourceController.java:70)
        at hudson.model.Executor.run(Executor.java:71)

        snolbu2 added a comment -

        I want this issue is closed because spericas's solution is worked on.
        But I have another problem and I want to create new issue.

        Thanks spericas !!
        Have a nice day.

        Santiago Pericas-Geertsen added a comment -

        Removing the the 'xi' namespace from exclude namespaces in the 'report.xsl' stylesheet seems to fix the
        problem.


          People

          • Assignee:
            Santiago Pericas-Geertsen
            Reporter:
            snolbu2
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: