Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: engine
    • Labels:
      None
    • Environment:

      Operating System: AIX
      Platform: Other

    • Issuezilla Id:
      23

      Description

      Hi, I have a problem.
      I set Japex in Hudson.
      First time is good, but Second is Out of work

      [Special Case]
      I remove 'xi' namespace in result.xsl according to issue num 22.

      [Environment]
      AIX 5.3
      JDK 1.5.0
      Hudson 1.200
      Ant 1.7

      [Configuration]
      Japex report files : trunk/reports/*/report.xml

      [Error Log]
      ----------------------------------------------------------------------------
      stressTest:
      [java] Reading configuration
      file '/usr/Weblogic/dev_server/Hudson/home/jobs/WAF/workspace/trunk/japexconfig.
      xml' ...
      [java] Estimated warmup time + run time is 3 seconds
      [java] JUnitDriver using 1 thread(s) on 4 cpu(s)
      [java] Run 1: TestDept,....
      [java] Time: 1.997
      [java]
      [java] OK (4 tests)
      [java]
      [java] ....
      [java] Time: 0.144
      [java]
      [java] OK (4 tests)
      [java]
      [java] ....
      [java] Time: 0.12
      [java]
      [java] OK (4 tests)
      [java]
      [java] ....
      [java] Time: 0.121
      [java]
      [java] OK (4 tests)
      [java]
      [java] ....
      [java] Time: 0.1
      [java]
      [java] OK (4 tests)
      [java]
      [java] ....
      [java] Time: 0.099
      [java]
      [java] OK (4 tests)
      [java]
      [java] ....
      [java] Time: 0.114
      [java]
      [java] OK (4 tests)
      [java]
      [java] ....
      [java] Time: 0.107
      [java]
      [java] OK (4 tests)
      [java]
      [java] ....
      [java] Time: 0.093
      [java]
      [java] OK (4 tests)
      [java]
      [java] ....
      [java] Time: 0.164
      [java]
      [java] OK (4 tests)
      [java]
      [java] 307.005,aritmean,307.005,geommean,307.005,harmmean,307.005
      [java] Generating reports ...
      [java] file:/usr/Weblogic/report/waf/reports/2008_04_11_20_59/report.xml
      [java] file:/usr/Weblogic/report/waf/reports/2008_04_11_20_59/report.html
      [mkdir] Created
      dir: /usr/Weblogic/dev_server/Hudson/home/jobs/WAF/workspace/trunk/reports
      [copy] Copying 24 files
      to /usr/Weblogic/dev_server/Hudson/home/jobs/WAF/workspace/trunk/reports

      BUILD SUCCESSFUL
      Total time: 3 minutes 19 seconds
      Recording test results
      Recording japex reports trunk/reports/*/report.xml
      /usr/Weblogic/dev_server/Hudson/home/jobs/WAF/builds/2008-04-11_20-54-
      57/japex/trunk/reports/2008_04_11_20_41/report.xml
      FATAL: null
      java.lang.NullPointerException
      at com.sun.japex.RegressionDetector.generateXmlReport
      (RegressionDetector.java:160)
      at hudson.plugins.japex.JapexPublisher.perform(JapexPublisher.java:140)
      at hudson.tasks.BuildStepCompatibilityLayer.perform
      (BuildStepCompatibilityLayer.java:33)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep
      (AbstractBuild.java:302)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep
      (AbstractBuild.java:290)
      at hudson.model.Build$RunnerImpl.post2(Build.java:134)
      at hudson.model.AbstractBuild$AbstractRunner.post
      (AbstractBuild.java:275)
      at hudson.model.Run.run(Run.java:767)
      at hudson.model.Build.run(Build.java:101)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:71)

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Santiago Pericas-Geertsen
            Reporter:
            snolbu2
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: