java3d
  1. java3d
  2. JAVA3D-110

D3D optimizeForSpace failed render geometry with large date set.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.3.2-dev
    • Fix Version/s: not determined
    • Component/s: j3d-core
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: PC

    • Issuezilla Id:
      110
    • Status Whiteboard:

      incomplete

      Show
      incomplete

      Description

      There is a bug that is related to D3D
      implementation with the following two options:
      -Dj3d.rend=d3d -Dj3d.optimizeForSpace=false

      When a large data set is rendered with all the triangle
      arrays constructed with by-reference vertex format,
      only a certain number of geometry arrays are rendered.
      The OGL version works very well while the D3D version fails
      to render properly with the following property set
      to false

      -Dj3d.optimizeForSpace=false

      Releate discussion thread.
      http://www.javadesktop.org/forums/thread.jspa?threadID=8665&tstart=30

      Large data set is in terms of number of geometries.
      Not in terms of single large geometry. It is verified
      that for a 500K TriangleArray can be displayed properly
      with or without optimizeForSpace under D3D.

      Reported here to be able to track it.

        Issue Links

          Activity

          kcr added a comment -

          Given that we don't have a test case, I am lowering to P5 and marking as
          "incomplete". In any case, this bug isn't as important, since we have pushed
          issue 329 back to the 1.6.0 release.

          kcr added a comment -

          Any chance we can get a test case? If not we will eventually close the issue,
          since we can't reproduce it. We will leave it open for at least another month.

          aces added a comment -

          I'll check what is possible to fix D3D native code side.

          kcr added a comment -

          Since there is no test case, I don't think it is worth spending any time on this
          one. There are other, higher priority bugs that need to be addressed.

          kcr added a comment -

          Closing as not reproducible.


            People

            • Assignee:
              java3d-issues
              Reporter:
              yowmhong
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: