java3d
  1. java3d
  2. JAVA3D-219

Add support for Non Power of Two textures

    Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.0
    • Fix Version/s: 1.5.0
    • Component/s: j3d-core
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      219

      Description

      Add support for Non Power of Two (NPOT) textures. The underlying APIs support
      this, so this change will consist of checking for support in the underlying API,
      reflecting the NPOT status in the DisplayConfiguration properties, disabling
      the POT testing when the textures are defined or modified if NPOT is supported,
      and updating the documentation.

        Activity

        kcr added a comment -

        Set target milestone to 1.5.0

        kcr added a comment -

        Change issue type to feature.

        kcr added a comment -

        Assign to jada.

        jada added a comment -

        Implemented in 1.5 beta1

        darwinjob added a comment -

        POT is still the requirement for Texture3D on ATI videocards (NVIDIA works
        fine). If you use NPOT Texture3D on ATI you get empty (white) textures.

        kcr added a comment -

        This is probably not a bug. NPOT textures will only display on cards that have
        the required HW support. Some cards (notably most ATI cards) lack this support.


          People

          • Assignee:
            jada
            Reporter:
            ddg
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: