javacc
  1. javacc
  2. JAVACC-8

Token manager should not use IOException to mark EOF

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: current
    • Fix Version/s: 5
    • Component/s: scanner generator
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      8

      Description

      Right now, the *CharStream classes throw IOException to indicate EOF reached.
      This exception is caught by the token manager to eventually return the EOF token.

      I would like to change this to throw a javacc-specific exception so that there
      is no confusion between the exception thrown by the *CharStream classes and the
      one thrown by the InputStream/Reader classes of java.io.

        Activity

        sreeni added a comment -

        Moving issues to the right subcomponent

        sreeni added a comment -

        assigning to self

        sreeni added a comment -

        Try for 4.0

        sreeni added a comment -

        We should do a big global sweep of this when everyone agrees on a design.

            • This issue has been marked as a duplicate of 108 ***
        paulcager added a comment -

        Postponed to 5.0


          People

          • Assignee:
            javacc-issues
            Reporter:
            sreeni
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: