• Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 6.0.7-5
    • Fix Version/s: 6.0.7-6
    • Component/s: examples
    • Labels:


      Today I tried to create a new customer/user for Duke's Forest, for the first time in quite a while, and typed a password that was too short. Instead of an error message in the little square I got


      I tried using incorrect values for some of the other fields and got the same problem – all that was displayed was




      Apparently the validation messages, which are in dukes-resources.jar, are not being found even though dukes-resources.jar is bundled in dukes-store.war.

      In the dukes-resources.jar file the messages are in java/ and java/

      In dukes-tutoring, the messages are in dukes-tutoring-war/src/java and are built into the WAR file, in WEB-INF/classes/ etc.

      So Eric and I copied the validation messages into dukes-store/src/java, and after redeployment the messages appear just fine.

      Are the validation messages needed anywhere besides dukes-store? I don't believe any entities are created in dukes-shipment, so removing them from dukes-resources and putting them into just dukes-store might be sufficient.

      I am about to check in some fixes for serialVersionUID (JAVAEETUTORIAL-107) and other cosmetic changes (changing StringBuffer to StringBuilder, adding @Override, line breaks, other NetBeans nits) and was checking to see if I had broken anything. But the same thing happens with the existing version on my other machine, so those fixes I am making haven't changed any behavior.


        Kim Haase created issue -
        William Markito made changes -
        Field Original Value New Value
        Status Open [ 1 ] In Progress [ 3 ]
        Kim Haase made changes -
        Status In Progress [ 3 ] Closed [ 6 ]
        Fix Version/s 6.0.7-6 [ 15852 ]
        Resolution Fixed [ 1 ]


          • Assignee:
            William Markito
            Kim Haase
          • Votes:
            0 Vote for this issue
            0 Start watching this issue


            • Created: