Issue Details (XML | Word | Printable)

Key: JAVAEETUTORIAL-176
Type: Improvement Improvement
Status: Resolved Resolved
Resolution: Fixed
Priority: Minor Minor
Assignee: Unassigned
Reporter: rcervera
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
javaeetutorial

Sample code lines should be shorter whenever possible to avoid line-wrapping in the HTML output

Created: 06/Jun/13 09:55 PM   Updated: 21/Aug/13 07:51 PM   Resolved: 21/Aug/13 07:51 PM
Component/s: None
Affects Version/s: 7.0.0
Fix Version/s: 7.0.3

Time Tracking:
Not Specified

Tags: html examples
Participants: Kim Haase and rcervera


 Description  « Hide

The HTML output seems to fit around 70 characters in one line for code examples. Line wrapping with CSS has been a great improvement, but the code is still difficult to read when it has more than a few long lines.



Kim Haase added a comment - 02/Jul/13 08:16 PM

Fixed bad breaks in jsf-advanced-cc.fm.


Kim Haase added a comment - 03/Jul/13 01:02 PM

Bad break in usingexamples.fm (Section 2.9.2.1) fixed as a result of JAVAEETUTORIAL-210.


Kim Haase added a comment - 03/Jul/13 01:56 PM

webapp.fm: Fixed bad break in web.xml servlet-class subelement; also fixed in hello1 example trunk and branch files. Fixed two bad breaks in GreetingServlet.java; also fixed in hello2 example trunk and branch files.


Kim Haase added a comment - 03/Jul/13 05:08 PM

jsf-intro.fm: fixed bad line breaks.

jsf-facelets.fm: fixed bad line breaks in Frame file as well as in guessnumber-jsf and reservation example files (trunk and branch).


Kim Haase added a comment - 03/Jul/13 05:45 PM

jsf-el.fm: Fixed duplicated item (and bad line break) in Table 9-2.

jsf-page.fm: Fixed bad line breaks, and some table formatting as well.


Kim Haase added a comment - 03/Jul/13 07:11 PM

jsf-develop.fm: Fixed bad line break, table formatting.

jsf-custom.fm: Fixed bad line breaks. Experimented with specifying "wide" as role for informal example. Fixed jsf-config.xml to reduce line lengths.


Kim Haase added a comment - 03/Jul/13 07:42 PM

jsf-configure.fm: Fixed bad line breaks.


Kim Haase added a comment - 03/Jul/13 08:43 PM

jms-concepts.fm, jms-examples.fm: fixed bad line breaks (also in producer, shareddurablesubscribererexample, websimplemessage examples).


Kim Haase added a comment - 09/Aug/13 08:35 PM

Now that the font for code examples is smaller, we can probably go back to having lines that are as long as the FrameMaker source will allow.


rcervera added a comment - 09/Aug/13 08:46 PM

Kim, should we close this issue then?


Kim Haase added a comment - 09/Aug/13 09:17 PM

Hm! Yes, maybe that's the best choice. We'd have to retitle it to something like "Code lines should fit on a FrameMaker line", which seems like a no-brainer.

It is unfortunate that our nightly RSB builds don't use the new stylesheets, so we can't test our fixes. I wonder if they could be changed to use them?


Kim Haase added a comment - 21/Aug/13 07:47 PM

Now that the nightly builds use the new stylesheets, maybe you could close this issue as "Works as Designed", Ricardo? That seems to be closest to the actual situation. I have reverted my "fixes".


rcervera added a comment - 21/Aug/13 07:51 PM

Works as designed with the new style sheets.


rcervera made changes - 21/Aug/13 07:51 PM
Field Original Value New Value
Status Open [ 1 ] Resolved [ 5 ]
Fix Version/s 7.0.3 [ 16500 ]
Resolution Fixed [ 1 ]