javaeetutorial
  1. javaeetutorial
  2. JAVAEETUTORIAL-181

Multiple para elements inside a bullet point in an ItemizedList do not render properly in HTML (See 52.1.1)

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 7.0.0
    • Fix Version/s: 7.0.2
    • Component/s: None
    • Labels:
      None

      Description

      They look fine on the PDF. In the HTML, the paragraphs and an image are not separated by any space. I don't know whether to reorganize the content or try to fix the template.

      1. figureInListCssFix.png
        44 kB
      2. ListPara.PNG
        86 kB
      3. paragraphsInListsCssFix.png
        62 kB

        Activity

        Ian Evans added a comment - - edited

        See the attachment for what it looks like if I add the following CSS to javaee-darb-fonts.css:

        ul .figure {
            padding-top: 10px;
        }
        
        rcervera added a comment -

        Thanks Ian, that fixes the figure in this case. I am unsure if that change would have unintended consequences elsewhere.

        Still the paragraphs inside the same bullet list item do not render properly, there is no space between them (see attachment). The easiest thing may be for me to rewrite this part without multiple paragraphs inside a bullet point if there's no other solution...

        rcervera added a comment -

        Paragraphs inside a list item not rendered properly.

        Kim Haase added a comment -

        I wouldn't change anything in the source, Ricardo – lots of chapters have lists (numbered as well as ordered) with multiple paragraphs, and we should really have a fix if possible.

        Kim Haase added a comment -

        The fix for figures looks good!

        Ian Evans added a comment -

        See the paragraphsInListsCssFix.png attachment for a fix for these by altering the following CSS style:

        .javaee #mainContent li p {
            line-height:1.5em;
            padding: 0em 0em .5em 0em;
            margin:auto;
        }
        
        rcervera added a comment -

        That's a great solution - thank you!

        jendrock added a comment -

        Since the fix looks good, could you please check it in, Ian? And then can you close the issue, since the problem is no longer there? Kim propagated the fix to the online docs on docs.oracle.com. Thanks.

        Ian Evans added a comment -

        Fixed online, and will be included in 7.0.2.

        I'm tracking our local changes to the post-processor template files in the project wiki here:
        https://java.net/projects/javaeetutorial/pages/JavaEEPostProcessorBugFixes


          People

          • Assignee:
            Unassigned
            Reporter:
            rcervera
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: