Issue Details (XML | Word | Printable)

Key: JAVAEETUTORIAL-238
Type: Bug Bug
Status: Closed Closed
Resolution: Won't Fix
Priority: Major Major
Assignee: Kim Haase
Reporter: evil850209
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
javaeetutorial

NullPoint error in chapter 8.5 Composite Components example code.

Created: 26/Aug/13 08:05 AM   Updated: 26/Aug/13 06:25 PM   Resolved: 26/Aug/13 06:25 PM
Component/s: examples
Affects Version/s: 7.0.1
Fix Version/s: None

Time Tracking:
Not Specified

Environment:

Java EE 7
GlasshFish 4.0

Issue Links:
Duplicate
 

Tags:
Participants: evil850209, Ian Evans and Kim Haase


 Description  « Hide

I am reading The Java EE 7 Tutorial from http://docs.oracle.com/javaee/7/tutorial/doc/jsf-facelets005.htm#GIQZR

After I typed the example code in the chapter 8.5 Composite Components in my IDE and run the example on GlassFish4.0, I got an error.

java.lang.NullPointerException
at java.util.concurrent.ConcurrentHashMap.putIfAbsent(ConcurrentHashMap.java:1078)
at com.sun.faces.util.Cache.get(Cache.java:116)
at com.sun.faces.application.view.FaceletViewHandlingStrategy.getComponentMetadata(FaceletViewHandlingStrategy.java:237)
at com.sun.faces.application.ApplicationImpl.createComponent(ApplicationImpl.java:951)
at javax.faces.application.ApplicationWrapper.createComponent(ApplicationWrapper.java:648)

Then I check the older version of this tutorial, I found a difference in email.xhtml code. The namespace has been changed from Java EE 7. After I changed the namespace back to JavaEE 6 version, it works.

Java EE 7

xmlns:composite="http://xmlns.jcp.org/jsf/composite"

Java EE 6

xmlns:composite="http://java.sun.com/jsf/composite"



Ian Evans added a comment - 26/Aug/13 04:59 PM

Ian Evans made changes - 26/Aug/13 04:59 PM
Field Original Value New Value
Link This issue duplicates JAVASERVERFACES_SPEC_PUBLIC-1213 [ JAVASERVERFACES_SPEC_PUBLIC-1213 ]
Kim Haase added a comment - 26/Aug/13 06:22 PM

I believe this is essentially a duplicate of https://java.net/jira/browse/JAVASERVERFACES-2868 (of which https://java.net/jira/browse/JAVASERVERFACES_SPEC_PUBLIC-1213 is also a duplicate, I believe). Several components do not work correctly with the new xmlns.jcp.org namespace at the first release of JSF 2.2. The fix for this problem will be in the next released version of JSF 2.2.x.

We document the namespaces the way they are supposed to work, rather than document the incorrect behavior. The facelets pages for the tutorial examples that use composite components (and a few other components) use the java.sun.com namespace so that the examples will run.


Kim Haase made changes - 26/Aug/13 06:22 PM
Status Open [ 1 ] Closed [ 6 ]
Assignee Kim Haase [ chaase3 ]
Fix Version/s 7.0.2 [ 16321 ]
Resolution Won't Fix [ 2 ]
Kim Haase made changes - 26/Aug/13 06:24 PM
Resolution Won't Fix [ 2 ]
Status Closed [ 6 ] Reopened [ 4 ]
Kim Haase made changes - 26/Aug/13 06:25 PM
Fix Version/s 7.0.2 [ 16321 ]
Kim Haase made changes - 26/Aug/13 06:25 PM
Affects Version/s 7.0.1 [ 16320 ]
Kim Haase made changes - 26/Aug/13 06:25 PM
Status Reopened [ 4 ] Closed [ 6 ]
Resolution Won't Fix [ 2 ]