javaeetutorial
  1. javaeetutorial
  2. JAVAEETUTORIAL-240

dukes-forest: Payment web service does not work

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 7.0.3
    • Component/s: examples
    • Labels:
      None

      Description

      The payment web service does not work in the current state of the application. Follow these steps to reproduce the issue:

      1. Start Glassfish Server

      2. Build and deploy the application:
      (this enables principal-to-role mapping and creates the required resources)
      mvn install

      3. Open a web browser:
      http://localhost:8080/dukes-store/

      4. Register as a new user

      5. Log in as the new user
      The log is successful on the page, but you get the following error message on the log:
      SEVERE: SEC1111: Cannot load group for JDBC realm user [ricardo@gmail.com].

      6. Add some products to the cart

      7. Check out
      You get the following errors on the log:


      WARNING: Following exception was thrown:
      java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
      [...]
      Caused by: javax.xml.ws.WebServiceException: Failed to access the WSDL at: http://RCERVERA-LAP:8080/dukes-store/PaymentService/__container$publishing$subctx/null?WSDL. It failed with:
      Server returned HTTP response code: 502 for URL: http://RCERVERA-LAP:8080/dukes-store/PaymentService/__container$publishing$subctx/null?WSDL.
      at com.sun.xml.ws.wsdl.parser.RuntimeWSDLParser.tryWithMex(RuntimeWSDLParser.java:249)
      at com.sun.xml.ws.wsdl.parser.RuntimeWSDLParser.parse(RuntimeWSDLParser.java:230)
      at com.sun.xml.ws.wsdl.parser.RuntimeWSDLParser.parse(RuntimeWSDLParser.java:193)
      at com.sun.xml.ws.wsdl.parser.RuntimeWSDLParser.parse(RuntimeWSDLParser.java:162)
      at com.sun.xml.ws.client.WSServiceDelegate.parseWSDL(WSServiceDelegate.java:359)
      at com.sun.xml.ws.client.WSServiceDelegate.<init>(WSServiceDelegate.java:321)
      at com.sun.xml.ws.client.WSServiceDelegate.<init>(WSServiceDelegate.java:230)
      at com.sun.xml.ws.client.WSServiceDelegate.<init>(WSServiceDelegate.java:212)
      at com.sun.xml.ws.client.WSServiceDelegate.<init>(WSServiceDelegate.java:208)
      at com.sun.xml.ws.spi.ProviderImpl.createServiceDelegate(ProviderImpl.java:112)
      at javax.xml.ws.Service.<init>(Service.java:92)
      at services.payment.forest.com.PaymentService.<init>(PaymentService.java:58)
      ... 36 more
      Caused by: java.io.IOException: Server returned HTTP response code: 502 for URL: http://RCERVERA-LAP:8080/dukes-store/PaymentService/__container$publishing$subctx/null?WSDL
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1625)
      at java.net.URL.openStream(URL.java:1037)
      at com.sun.xml.ws.wsdl.parser.RuntimeWSDLParser.createReader(RuntimeWSDLParser.java:983)
      at com.sun.xml.ws.wsdl.parser.RuntimeWSDLParser.resolveWSDL(RuntimeWSDLParser.java:384)
      at com.sun.xml.ws.wsdl.parser.RuntimeWSDLParser.parse(RuntimeWSDLParser.java:215)
      ... 46 more

      SEVERE: EJB5070: Exception creating stateless session bean : [PaymentHandler]
      WARNING: EJB5184:A system exception occurred ...


      Possible cause: the JDBC realm is not working properly.
      Possible line of investigation: New Password Encryption Algorithm field that we are not specifying. See the last comment on the following link:
      http://stackoverflow.com/questions/12067410/glassfish-3-1-2-jdbcrealm-configuration

      (digestrealm-password-enc-algorithm property if we want to add it in glassfish-resources.xml)

        Activity

        rcervera added a comment -

        The payment web service works properly. The problem was the proxy configuration in GlassFish. Remove the http.proxyHost and http.proxyPort properties from your server, then the payment works fine.

        We made changes to the installation process. Verify as follows:

        1. Remove any previous authentication realms:
        asadmin delete-auth-realm jdbcRealm

        2. Configure resources and realms on dukes-forest/
        mvn exec:exec

        3. Build and deploy the application:
        mvn install

        4. Test normally and look at the server log. Payments less than $1000 are processed.


          People

          • Assignee:
            Unassigned
            Reporter:
            rcervera
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: