Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Works as designed
    • Affects Version/s: 6.0.7-2
    • Fix Version/s: 6.0.7-3
    • Component/s: examples
    • Labels:
      None

      Description

      The endpoint activation method is never called in the mailconnector example. The MDB needs to be fixed so it can perform its function as a listener. This can be done by examining (and possibly reusing) the code in the original GlassFish Samples. An explanation of endpoint activation can be found on page 16 of the white paper by Alejandro Murillo and Binod P.G. entitled "Creating Resource Adapters with J2EE Connector Architecture 1.5" circa 2004.

        Activity

        Kim Haase added a comment -

        Since the application now retrieves the messages synchronously through the managed bean rather than receiving them asynchronously through the MDB, the MDB exists only to activate the resource adapter.


          People

          • Assignee:
            chinmayee_srivathsa
            Reporter:
            jendrock
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: