javaeetutorial
  1. javaeetutorial
  2. JAVAEETUTORIAL-86

Explanation of contexts is confusing and unclear in JEE6 Tutorial

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 6.0.7-5
    • Fix Version/s: 7.0.2
    • Component/s: doc
    • Labels:
      None

      Description

      Here is the definition of 'context' given in the CDI section of the JEE6 Tutorial:

      Overview of CDI

      "Contexts: The ability to bind the lifecycle and interactions of stateful components to well-defined but extensible lifecycle contexts"

      This is a circular definition. What is a context. How is it different from a 'lifecycle context'? If it isn't different then it really is a circular definition which isn't really a definition. If they are different things, why do they have the same name?

      This is probably a good definition for someone who who knows the subject; but not for someone who really needs the tutorial.

        Activity

        jendrock added a comment -

        This passage was not meant to be a definition of the term "contexts" but was intended to describe the services provided by the technology (CDI) in this area. This is indicated by the text that introduces the bullet list. In fact, the term isn't defined in the CDI specification or anywhere else that we could find! If you can find a valid definition, we would be glad to include it in the tutorial.

        jendrock added a comment -

        I suggest that you look at this issue and then use the definition provided by Paul Davies in the first section of Chapter 9, "Using Contexts and Dependency Injection for the Java EE Platform", in the Oracle Fusion Middleware Developing Applications for Oracle WebLogic Server 12c Release 1 book. The meaning is essentially the same, but the grammar is slightly improved.

        Ian Evans added a comment -

        Ricardo: reassigning Chinmayee's CDI issues to you. This may have been fixed in the Java EE 7 Tutorial.

        rcervera added a comment -

        Fixed this issue in the source using Eric's suggestion.


          People

          • Assignee:
            rcervera
            Reporter:
            billick
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: