javamoney
  1. javamoney
  2. JAVAMONEY-12

Align Integration Requirements With OpenJDK

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: 0.9
    • Component/s: Impl: RI
    • Labels:
      None
    • Environment:

      Targeting SE 9.

      Description

      It is viable to discuss with Oracle JDK architects the required constraints on value type and accessor design. As a result of this task a small document should be written or provided that states the common requirements for SE JSRs like this. As an advantage this document can also be shared with other JSRs that are not lead by Oracle.

        Activity

        atsticks created issue -
        atsticks made changes -
        Field Original Value New Value
        Summary Core Module Align Integration Requirements With OpenJDK
        Original Estimate 2 days [ 172800 ]
        Remaining Estimate 2 days [ 172800 ]
        Issue Type New Feature [ 2 ] Task [ 3 ]
        Assignee vgrazi [ vgrazi ]
        Environment Java SE 7, if possible also compatible with 6. Targeting SE 9.
        Description Core area defining the main value types for currency and monetary amounts, including arithmetic operations and SPIs. It is viable to discuss with Oracle JDK architects the required constraints on value type and accessor design. As a result of this task a small document should be written or provided that states the common requirements for SE JSRs like this. As an advantage this document can also be shared with other JSRs that are not lead by Oracle.
        Due Date 2014-03-14 00:00:00.0
        Tags core currency monetary amount core JSR SE design
        atsticks made changes -
        Component/s Platform: SE/JDK Adaptations [ 14830 ]
        atsticks made changes -
        Fix Version/s 1.0-b01 [ 16318 ]
        Hide
        keilw added a comment -

        Given Java 9 has been deferred to early 2016 this issue probably won't matter at all for 1.0

        Show
        keilw added a comment - Given Java 9 has been deferred to early 2016 this issue probably won't matter at all for 1.0
        keilw made changes -
        Fix Version/s 0.4-EDR1 [ 16318 ]
        Priority Major [ 3 ] Minor [ 4 ]
        Due Date 2014-03-14 00:00:00.0 2015-03-14 00:00:00.0
        keilw made changes -
        Component/s Impl: RI [ 14824 ]
        Component/s Impl: SE/JDK Adaptations [ 14830 ]
        keilw made changes -
        Fix Version/s 0.9 [ 16866 ]
        atsticks made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Won't Fix [ 2 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            atsticks
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 2 days
              2d
              Remaining:
              Remaining Estimate - 2 days
              2d
              Logged:
              Time Spent - Not Specified
              Not Specified