javaserverfaces
  1. javaserverfaces
  2. JAVASERVERFACES-1492

Component bindings incompatible with View Scope

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.2_gf32_m2, 2.2.0-m01
    • Component/s: None
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1,492
    • Status Whiteboard:

      size_medium importance_large

      Show
      size_medium importance_large

      Description

      If a component binding is used with a View scoped bean, a new instance of the bean will be temporarily
      instantiated to receive the binding, but will then be replaced by the View scoped instance, causing the set
      binding value to be lost.

      1. changebundle.txt
        9 kB
        Ed Burns
      2. Echo.java
        3 kB
        tedgoddard
      3. echo1.xhtml
        3 kB
        tedgoddard
      4. i_mojarra_1492_regression-20120124-1725.patch
        7 kB
        Ed Burns

        Activity

        harrypham added a comment -

        Thank you Manfred for replying. According to this site http://javaserverfaces-spec-public.java.net/nonav/2_2/planning/JSF_2_2_WORKING_SET.html, Sprint 20 will be on 10/15/2012, is sprint 20 is the release candidate of JSf 2.2?

        Manfred Riem added a comment -

        No, that is a release for public review. You should consider that a milestone release.

        balusc added a comment -

        I can't reproduce this problem on 2.1 anymore since 2.1.18. Since this version, taghandlers started to work fine together with view scoped beans. I'm not sure which 2.1.18 issue exactly fixed it for 2.1 as well (note that this ticket was targeted at 2.2).

        webelcomau added a comment -

        Thanks Ted Goddard for reporting this, Ed Burns and team for fixing this, Ryan Lubke and BalusC (and others) for investigating this and referencing it elsewhere such as on Stackoverflow. I consider this an extremely important improvement to JSF2, because it solves many problems and opens up many new possibilities for controlling what is built as opposed to what is rendered under @ViewScoped. Example of a recursion problem it solves: http://stackoverflow.com/questions/16665705/jsf-how-prevent-stackoverflow-due-to-recursion-during-build-phase-despite-rend/16784371#16784371

        kwutzke added a comment -

        @balusc: we are using Mojarra 2.1.22 in a PrimeFaces 3.4.2 + Seam 3 @ViewScoped environment (binding on a bean annotated @ViewScoped) and all these beans get reinstantiated on every AJAX request, so unfortunately we cannot confirm your statement that this has been fixed. Is there a way we can work out what might be wrong, either by email, forum, or SO?


          People

          • Assignee:
            Ed Burns
            Reporter:
            tedgoddard
          • Votes:
            12 Vote for this issue
            Watchers:
            15 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: