javaserverfaces
  1. javaserverfaces
  2. JAVASERVERFACES-1567

Implicit navigation doesn't query Facelet ResourceResolvers when attempting to match a view

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.1_gf31_m7
    • Component/s: navigation
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1,567
    • Status Whiteboard:

      size_medium importance_medium

      Show
      size_medium importance_medium

      Description

      The common use case for ResourceResolver implementations is to enable the
      packaging of views within JARs. However, if a developer goes this route,
      implicit navigation can't be used as implicit navigation requires a physical
      resource within the docroot of the web application.

      1. changebundle.txt
        16 kB
        Ed Burns
      2. fixResourceResolver-1.patch
        11 kB
        lu4242

        Issue Links

          Activity

          Ed Burns added a comment -

          Committed revision 8738.

          Ed Burns added a comment -
          Ed Burns added a comment -

          Committed revision 8761.

          Ed Burns added a comment -

          This is a duplicate of JAVASERVERFACES_SPEC_PUBLIC-893.

          Manfred Riem added a comment -

          Closing out resolved issue


            People

            • Assignee:
              Ed Burns
              Reporter:
              Ryan Lubke
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: