Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      158

      Description

      Despite the JSP 2.1 alignment, there is a defect in the JSF 1.2 RI such that it
      returns null for Application.getExpressionFactory if it wasn't able to pull one
      from the JSP implementation.

      This does need to be looked at in the specification w/ how the two relate. My
      suggested fix is to attempt to load/check for an ExpressionFactory from JSP 2.1,
      use it if available, otherwise check for an init-param in the web.xml of a class
      type for an ExpressionFactory. This defaults to the EL-RI.

      JSF 1.2 releases of the reference implementation would now have a dependency on
      the EL-API and the EL-RI, but now usuable without JSP. I look at it this way,
      since JSF 1.1 worked previously with other ViewHandlers, and now doesn't in JSF
      1.2, then the specification is broken, but can be fixed within the reference
      implementation easily.

        Activity

        jhook added a comment -

        Created an attachment (id=86)
        modifications to load from init param or RI if JSP 2.1 is not found

        Ed Burns added a comment -

        I've committed the patch, but please make an addition to a test case to exercise
        this code for regression. You may want to consider adding it to the existing
        unit test for ConfigureListener.

        Ed Burns added a comment -

        Reclassify as feature.

        jayashri added a comment -

        Fix checked in

        Manfred Riem added a comment -

        Closing out issue


          People

          • Assignee:
            jhook
            Reporter:
            jhook
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: