Issue Details (XML | Word | Printable)

Key: JAVASERVERFACES-1651
Type: Bug Bug
Status: Closed Closed
Resolution: Won't Fix
Priority: Major Major
Assignee: Ed Burns
Reporter: lgraf
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
javaserverfaces

Validation for @ViewScoped values in addtion with the context paramter "javax.faces.INTERPRET_EMPTY_STRING_SUBMITTED_VALUES_AS_NULL" not works correctly

Created: 04/May/10 03:03 AM   Updated: 08/Feb/12 04:38 PM   Resolved: 08/Feb/12 04:38 PM
Component/s: conversion
Affects Version/s: 2.0.2
Fix Version/s: 2.0.next

Time Tracking:
Not Specified

File Attachments: 1. GZip Archive SimpleValidation.tar.gz (3 kB) 04/May/10 03:10 AM - lgraf

Environment:

Operating System: Linux
Platform: All


Issuezilla Id: 1,651
Status Whiteboard:

size_large importance_medium

Tags:
Participants: Ed Burns, lgraf and Manfred Riem


 Description  « Hide

If validation fails for a @ViewScoped value and the context paramter
"javax.faces.INTERPRET_EMPTY_STRING_SUBMITTED_VALUES_AS_NULL" is set to true,
not the submitted value(the not valid value) is shown. Instead the old value
from the managed bean is shown. This is very misleading for the user, because he
don't see the value for whom the validation has failed.



lgraf added a comment - 04/May/10 03:10 AM

Created an attachment (id=1146)
small maven based project with whom the above described behaviour can be reproduced.


lgraf added a comment - 04/May/10 03:16 AM

To reproduce:
1. Enter a value in the as required marked text field (the second) and hit submit.
2. Delete the value and submit again -> the old value from the bean will be shown

Steps to get normal behaviour:
1. Change the scope of the managed bean to request.
2. Set the context paramter
"javax.faces.INTERPRET_EMPTY_STRING_SUBMITTED_VALUES_AS_NULL" to false


Ed Burns added a comment - 04/May/10 03:20 AM

Thank you so much for including a maven test. I do things TDD style and this makes it much more
likely that I will get to it sooner.


lgraf added a comment - 04/May/10 03:25 AM

I forgot, there are already exists an issue with
"javax.faces.INTERPRET_EMPTY_STRING_SUBMITTED_VALUES_AS_NULL", with a slightly
different behaviour (#1375). Maybe this is helpfull ...


Ed Burns added a comment - 04/May/10 03:33 AM

Not vital for 2.0.3


Ed Burns added a comment - 22/Jun/10 09:29 PM

triage


Manfred Riem added a comment - 08/Feb/12 04:38 PM

We recommend upgrading to the latest 2.1 release.