javaserverfaces
  1. javaserverfaces
  2. JAVASERVERFACES-1771

When WEB-INF/beans.xml exists, preRenderView event listener is called twice per one request.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Duplicate
    • Affects Version/s: 2.0.3
    • Fix Version/s: None
    • Component/s: event processing
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: GlassFish 3.0.1

    • Issuezilla Id:
      1,771
    • Status Whiteboard:

      size_medium importance_medium

      Show
      size_medium importance_medium

      Description

      When WEB-INF/beans.xml exists, preRenderView event listener is called twice per
      one request.

        Issue Links

          Activity

          slopetown added a comment -

          Created an attachment (id=1250)
          sample program

          Ed Burns added a comment -

          Target GlassFish 3.2.

          slominskir added a comment -

          I wonder if this has anything to do with the issue mentioned here:

          http://www.coderanch.com/t/509746/JSF/java/duplicate-call-preRenderView-event

          Manfred Riem added a comment -

          Can you verify if this is still an issue with the latest 2.1 release?

          Manfred Riem added a comment -

          Lowering priority because of no response

          Manfred Riem added a comment -

          Lowering priority because of no response

          balusc added a comment -

          I can reproduce it with Mojarra 2.1.17 on Glassfish 3.1.2.2. A testcase can be found here: http://stackoverflow.com/questions/14598720/prerenderview-event-order-and-placement This is a rather awkward problem.

          balusc added a comment -

            People

            • Assignee:
              Unassigned
              Reporter:
              slopetown
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: