javaserverfaces
  1. javaserverfaces
  2. JAVASERVERFACES-1784

Forms inside custom composite componenents is getting reset if error

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0.3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1,784
    • Status Whiteboard:

      size_medium importance_medium

      Show
      size_medium importance_medium
    • Tags:

      Description

      I created a panelBox composite component with an insertChildren inside it.
      Nothing special.

      <cc:interface>
      </cc:interface>

      <cc:implementation >
      <div ...... >
      <cc:insertChildren/>
      </div>
      </cc:implementation>

      When a use this componenent inside a form like this:

      <myCC:ccName>
      <h:form>
      ...
      </h:form>
      </myCC:ccName>

      when the form is submitted, if there is an error (validation errors)
      the form values are reset.

      The form values are not reset if I don't use the composite componenent.
      I don't have this behavior with Mojarra 2.0.2 FCS, I only have it with
      the 2.0.3 version.

      NB: I have the code that reproduces the problem, i can submit it if necessary.

        Activity

        jab32 created issue -
        kenaiadmin made changes -
        Field Original Value New Value
        issue.field.bugzillaimportkey 1784 31050
        rogerk made changes -
        Tags 3_1-exclude
        rogerk added a comment -

        Exclude GlassFish 3.1.
        Reason: Too risky at this time.

        rogerk added a comment -

        triage

        rogerk made changes -
        Fix Version/s 2.2 [ 10944 ]
        Fix Version/s unscheduled [ 10948 ]
        Status Whiteboard size_medium importance_medium
        arjan tijms added a comment -

        JAVASERVERFACES-1991 is actually a duplicate of this, but since all the action seems to be taking place there, perhaps this one should be closed?

        rogerk added a comment -
        rogerk made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Duplicate [ 3 ]
        Manfred Riem made changes -
        Resolution Duplicate [ 3 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Manfred Riem made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Fix Version/s 2.2-m01 [ 15544 ]
        Fix Version/s 2.2 [ 10944 ]
        Resolution Duplicate [ 3 ]
        rogerk added a comment -

        reopen for fox version

        rogerk made changes -
        Resolution Duplicate [ 3 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        rogerk added a comment -

        no fix version

        rogerk made changes -
        Fix Version/s 2.2-m01 [ 15544 ]
        rogerk added a comment -
        rogerk made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Resolution Duplicate [ 3 ]
        Manfred Riem made changes -
        Component/s implementation [ 10535 ]

          People

          • Assignee:
            rogerk
            Reporter:
            jab32
          • Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: