Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0.6, 2.1.2
    • Component/s: None
    • Labels:
      None
    • Environment:

      2.0.x and 2.1.x

    • Status Whiteboard:

      size_small importance_medium jsf_2_1_2 jsf_2_0_x

      Show
      size_small importance_medium jsf_2_1_2 jsf_2_0_x

      Description

      In the com.sun.faces.application.resource.ZipDirectoryEntryScanner constructor, there is the following code :

      068. Set<String> webInfLibJars = extContext.getResourcePaths("/WEB-INF/lib");
      [...]
      073. for (String cur : webInfLibJars) {

      It happens that /WEB-INF/lib folder is not mandatory and then the webInfLibJars may be null.
      Thus, the for loop is throwing NPE (I've tested on JOnAS Application server)

      A check should be added :
      if (webInfLibJars != null) {
      for (String cur : webInfLibJars) {

      The problem is present in both 2.0.x and 2.1.x
      http://java.net/projects/mojarra/sources/svn/content/branches/MOJARRA_2_0X_ROLLING/jsf-ri/src/main/java/com/sun/faces/application/resource/ZipDirectoryEntryScanner.java?rev=9007
      http://java.net/projects/mojarra/sources/svn/content/branches/MOJARRA_2_1X_ROLLING/jsf-ri/src/main/java/com/sun/faces/application/resource/ZipDirectoryEntryScanner.java?rev=9007

        Activity

        rogerk added a comment -

        fix version

        rogerk added a comment -

        fix version

        rogerk added a comment -

        fix version

        rogerk added a comment -

        fix version

        rogerk added a comment -

        fix version


          People

          • Assignee:
            rogerk
            Reporter:
            benoitf
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 10 minutes
              10m
              Remaining:
              Remaining Estimate - 10 minutes
              10m
              Logged:
              Time Spent - Not Specified
              Not Specified