Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.1.1
    • Fix Version/s: None
    • Component/s: ajax
    • Labels:
      None
    • Environment:

      Windows 7, Java 1.6.0_27, Glassfish 3.1.1 build 12, Jsf mojarra 2.1.3

      Description

      When there is more than one form on the page, f:ajax execute attribute deals with enclosing form components only. Here's an example that doesn't work:

      <h:form id="f1">
      <h:commandButton id="prev" action="#

      {test.prev}" value="Previous">
      <f:ajax execute=":f2:test" render=":f2:test" />
      </h:commandButton>
      </h:form>
      <h:form id="f2">
      <h:inputText id="test" value="#{test.currPage}" />
      </h:form>

      And this one works:

      <h:form id="fok">
      <h:commandButton id="prevok" action="#{test.prev}

      " value="Previous">
      <f:ajax execute="testok" render="testok" />
      </h:commandButton>
      <h:inputText id="testok" value="#

      {test.currPage}

      " />
      </h:form>

      Managed bean "test" is request scoped. In mojarra 1.2 apps this has easily been achieved with help of richfaces 3.x a4j:support tag. This issue is related to JAVASERVERFACES-1719 (f:ajax execute=@all does the same as execute=@form ). There are common situations when there's one main form, and other one handling dialogs or modal panels. Communication between these two forms is highly needed.

        Activity

        rogerk added a comment -

          People

          • Assignee:
            rogerk
            Reporter:
            cernicb
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: