javaserverfaces
  1. javaserverfaces
  2. JAVASERVERFACES-2240

Add support for c:forEach-like begin and end attribtues to ui:repeat

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.1.3
    • Fix Version/s: None
    • Component/s: facelets
    • Labels:
      None

      Description

      It would be nice if <ui:repeat> supports the following construct.

      <ui:repeat begin="#{bean.begin}" end="#{bean.end}">
        <div>foo</div>
      </ui:repeat>
      

      Which acts like JSTL's <c:forEach begin="1" end="10">, but then with EL support in the attributes.

        Issue Links

          Activity

          Aditya added a comment -

            People

            • Assignee:
              Unassigned
              Reporter:
              balusc
            • Votes:
              4 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: