javaserverfaces
  1. javaserverfaces
  2. JAVASERVERFACES-2334

<f:ajax> tag performance degrades significantly with large page sizes.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Works as designed
    • Affects Version/s: 2.1.3
    • Fix Version/s: None
    • Component/s: ajax
    • Labels:
      None
    • Environment:

      GlassFish 3.1.1 (Mojarra 2.1.3), JBoss 7.1 and Tomcat 7.0 (Mojarra 2.1.5) running on Windows 7 64bit Sun/Oracle 1.6.0_30 java 32bit

      Description

      <f:ajax> tag degrades to performance of regular JSF 2 post as the xhtml page size increases. Attached is a sample xhtml page and backing bean that exhibits the problem. The page has 2 <f:form> tags the first one is very small and has the <f:agax> tag. The second <h:form> is large and contains a lot of html.

      Problem happens in GlassFish 3.1.1, JBoss 7.1 and Tomcat 7.0

      1. AjaxTest.xhtml
        313 kB
        rkite
      2. PageAjaxTest.java
        0.6 kB
        rkite

        Activity

        rkite added a comment -

        Although flipping this flag helps performance. Two and a half second turn around time on more complex pages is very slow although better than 12 seconds with the default. It should be under 1/10 of a second to execute an Ajax request with JSF 2. It is under 1/20 of a second when doing straight Ajax with a Servlet on the same page. If Myfaces does this fast without changing settings then it definitely can be done. A little bit of performance tuning like avoiding N based searches on lists etc. could go a long way.

        rogerk added a comment -

        I certainly agree that there is room for performance improvement in some of these other areas.
        I am looking at Facelets related issues like http://java.net/jira/browse/JAVASERVERFACES-2228.
        As you run across other areas that impact performance, please file appropriate issues and suggestions, patches, etc. That will speed things up (no pun intended)..

        rogerk added a comment -

        per previous comments

        ova2 added a comment -

        The issue still exists. What happened between 2.1.3 and 2.1.8? The performance difference is huge. 2.1.3 was much faster for ajax requests for the same JSF configuration. Forget config. parameters please. Something "bad" happend in the last Mojarra implementations. Switch from 2.1.3 to the last 2.1.8 sometimes adds 3-4 sek. more for ajax calls. I don't know if it's composite components or something else. Rolling back to 2.1.3. Frustration...

        codeturner added a comment -

        Note that this issue has been cloned and fixed as JAVASERVERFACES-2494.


          People

          • Assignee:
            rogerk
            Reporter:
            rkite
          • Votes:
            11 Vote for this issue
            Watchers:
            17 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: