Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.1.8, 2.2.0-m01
    • Fix Version/s: None
    • Component/s: view handling
    • Labels:
      None

      Description

      If you put a <ui:include> tag before a composite component that nests other composite components, you'll get this:

      javax.faces.view.facelets.TagException: /resources/lib/useboth.xhtml @19,33 <lib:greet1> Tag Library supports namespace: http://java.sun.com/jsf/composite/lib, but no tag was defined for name: greet1
      com.sun.faces.facelets.compiler.CompilationManager.pushTag(CompilationManager.java:304)
      com.sun.faces.facelets.compiler.SAXCompiler$CompilationHandler.startElement(SAXCompiler.java:268)
      com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:501)

      I've verified the error on a 2.1.8 snapshot and on a 2.2 snapshot. This does not occur on 2.1.7. I'm seeing this in a version taken from a 2.1.8 snapshot in late February. So it was broken some time before March. I'm guessing it might have something to do with JAVASERVERFACES-2328. But that's just a guess at this point.

      I'm attaching a maven project that builds a tiny app to reproduce the problem.

      Also see:
      https://issues.jboss.org/browse/AS7-4366
      https://community.jboss.org/message/724991
      https://community.jboss.org/thread/196737

        Issue Links

          Activity

          tiagowanke added a comment -

          Whats the workaround?

          ChrisTh added a comment -

          See https://community.jboss.org/message/724991
          Also works for regular usage of composite components.

          ceefour added a comment -

          +1 for this ...!

          dev_s added a comment - - edited

          I have created a BLOCKER issue for this. Please instead comment on that. I think this one with minor priority doesn't represent the severity of problem correctly.

          Here's the link
          http://java.net/jira/browse/JAVASERVERFACES-2437

          ova2 added a comment -

          I can not believe. We faced this problem today after an upgrade to Mojarra 2.1.9. A simple (not nested) composite component fails while web app is deployed on JBoss 7.1.1 final. The problem is that we can't switch to MyFaces because JBoss doesn't allow that (https://issues.jboss.org/browse/AS7-3940) And now? Critical issue!


            People

            • Assignee:
              Ed Burns
              Reporter:
              ssilvert
            • Votes:
              10 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: