Issue Details (XML | Word | Printable)

Key: JAVASERVERFACES-2583
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Major Major
Assignee: Manfred Riem
Reporter: BrunoReX
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
javaserverfaces

Character encoding always detected as UTF-8

Created: 09/Nov/12 01:57 PM   Updated: 17/Sep/13 05:12 PM   Resolved: 17/Sep/13 05:12 PM
Component/s: None
Affects Version/s: 2.1.13, 2.1.14
Fix Version/s: 2.2.3

Time Tracking:
Not Specified

Environment:

Windows 7
Apache Tomcat 7.0.30
Eclipse IDE


Tags: character encoding utf-8
Participants: BrunoReX and Manfred Riem


 Description  « Hide

When I updated my JSF to version 2.1.4 from 2.1.3, the character encoding of the pages started to get detected as UTF-8, even though I specified ISO-8859-1. And as soon as I reverted to version 2.1.3, it started working again.

I was able to reproduce the problem with this xhtml page that has nothing on it.

<?xml version="1.0" encoding="ISO-8859-1" ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"
xmlns:f="http://java.sun.com/jsf/core"
xmlns:h="http://java.sun.com/jsf/html"
xmlns:ui="http://java.sun.com/jsf/facelets">
<h:head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
</h:head>
<h:body></h:body>
</html>



Manfred Riem added a comment - 09/Nov/12 02:11 PM

Can you please try the latest 2.1 release?


BrunoReX added a comment - 09/Nov/12 02:26 PM

Sorry, I meant 2.1.13 and 2.1.14.


Manfred Riem added a comment - 22/Jan/13 03:01 PM

Can you try using the h:doctype tag?


BrunoReX added a comment - 24/Jan/13 01:15 AM

Like this? Doesn't seem to make any difference, tested with 2.1.17.

test.xhtml
<?xml version="1.0" encoding="ISO-8859-1" ?>
<html xmlns="http://www.w3.org/1999/xhtml"
	xmlns:f="http://java.sun.com/jsf/core"
	xmlns:h="http://java.sun.com/jsf/html"
	xmlns:ui="http://java.sun.com/jsf/facelets">
<h:doctype rootElement="html"
	public="-//W3C//DTD XHTML 1.0 Transitional//EN"
	system="http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd" />
<h:head>
	<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
</h:head>
<h:body></h:body>
</html>

Manfred Riem added a comment - 20/Mar/13 03:58 PM

Can you test the original against 2.1.20? Thanks!


BrunoReX added a comment - 24/Mar/13 02:44 PM

Same issue with 2.1.20, tested with both test pages.


Manfred Riem added a comment - 17/Sep/13 05:12 PM

I have verified against 2.2.3 and I cannot reproduce this. Closing as "Cannot Reproduce"