Issue Details (XML | Word | Printable)

Key: JAVASERVERFACES-2618
Type: Bug Bug
Status: Closed Closed
Resolution: Won't Fix
Priority: Major Major
Assignee: Manfred Riem
Reporter: Thomas Möller
Votes: 1
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
javaserverfaces

Tag libraries with aggregated composite library (composite-library-name) and additional tags cause warnings.

Created: 29/Nov/12 12:07 PM   Updated: 16/Sep/13 05:07 PM   Resolved: 16/Sep/13 05:07 PM
Component/s: facelets
Affects Version/s: 2.1.14
Fix Version/s: None

Time Tracking:
Not Specified

File Attachments: 1. Zip Archive jsf-bug.zip (4 kB) 29/Nov/12 12:08 PM - Thomas Möller


Tags:
Participants: Manfred Riem and Thomas Möller


 Description  « Hide

If you define a facelets tag library that aggregates a composite library via <composite-library-name> and that defines additional tags via <tags> warnings are emitted if one of the additional (non-composite-component) tags is used in a page. The reason for this is explained in JAVASERVERFACES-2416. (There is also a patch available.)



Thomas Möller added a comment - 29/Nov/12 12:08 PM

The bug can be reproduced with the attached project.


Manfred Riem added a comment - 16/Sep/13 05:07 PM

After looking into this I am going to close this as "Won't fix" as it is key that the ordering of first trying the get the resource and then executing the super class method is maintained. Note the message is there for the developer to signal something MIGHT be wrong.