javaserverfaces
  1. javaserverfaces
  2. JAVASERVERFACES-2621

ajax calls are lost if fired rapidly by browser

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Works as designed
    • Affects Version/s: 2.2.0-m04
    • Fix Version/s: None
    • Component/s: ajax
    • Labels:
      None
    • Environment:

      glassfish

      Description

      If I fire ajax calls rapidly through javascript in client, some of them are lost.
      I trace them down to
      jsf.js

      delayHandler = setTimeout(sendRequest, delayValue);
      

      If I pass "delay:none" to option, all calls are sent to server.

        Activity

        jasonzhang2002gmailcom added a comment -

        I am using fireFox 12.0. I have a form with fields like A, B and C. C depends on B, and B depends on A. At loading time, I fire "valueChange" event on A and B to adjust visual display. The event will trigger ajax call. However, only one ajax call is through.

        rogerk added a comment -

        This works as specified in the specification (tag library docs).
        If delay is used it only pertains to the current request.
        The default is no delay.

        jasonzhang2002gmailcom added a comment -

        No, The problem is that some ajax calls are lost if I leave delay to default(I do not specify delay in my ajax call). Please reopen this, I will attach a simple eclipse project to produce this reliably.
        I verified my project in JSF 2.1_14, there is no any problem.
        I also found that there problem exists only in Developement Stage.

        -jason

        jasonzhang2002gmailcom added a comment -

        This is fixed in milestone 6. You can leave this as closed.


          People

          • Assignee:
            rogerk
            Reporter:
            jasonzhang2002gmailcom
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: