Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.1.14
    • Fix Version/s: None
    • Component/s: managed bean
    • Labels:
      None

      Description

      a getter method of a managed bean WILL be called 3 times,if my method name prefix is get ,but not a getter of field,then it will be call 3 time logic,why not call one time?
      @ManagedProperty before class structure,if i have some content get from my field but @ManagedProperty is init after structure now,it will be null.that is not good,annotation is make set vale easier.

      and sorry my english is poor,thank you read it.

        Activity

        rogerk added a comment -

          People

          • Assignee:
            rogerk
            Reporter:
            chaodongyue
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: