javaserverfaces
  1. javaserverfaces
  2. JAVASERVERFACES-2681

Migrate JAVASERVERFACES-2347 to new test harness

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.1.17, 2.2.0-m08
    • Fix Version/s: 2.1.18, 2.2.0-m09
    • Component/s: None
    • Labels:
      None

      Issue Links

        Activity

        Manfred Riem added a comment -

        Applied to 2.1 branch,

        svn commit -m "Fixes http://java.net/jira/browse/JAVASERVERFACES-2681, migrating JAVASERVERFACES-2347 to new test harness."
        Deleting jsf-test\JAVASERVERFACES-2347
        Sending jsf-test\build.xml
        Adding test\agnostic\facelets
        Adding test\agnostic\facelets\core
        Adding test\agnostic\facelets\core\pom.xml
        Adding test\agnostic\facelets\core\src
        Adding test\agnostic\facelets\core\src\main
        Adding test\agnostic\facelets\core\src\main\java
        Adding test\agnostic\facelets\core\src\main\java\com
        Adding test\agnostic\facelets\core\src\main\java\com\sun
        Adding test\agnostic\facelets\core\src\main\java\com\sun\faces
        Adding test\agnostic\facelets\core\src\main\java\com\sun\faces\test
        Adding test\agnostic\facelets\core\src\main\java\com\sun\faces\test\agnostic
        Adding test\agnostic\facelets\core\src\main\java\com\sun\faces\test\agnostic\facelets
        Adding test\agnostic\facelets\core\src\main\java\com\sun\faces\test\agnostic\facelets\core
        Adding test\agnostic\facelets\core\src\main\java\com\sun\faces\test\agnostic\facelets\core\ActionListenerBean.java
        Adding test\agnostic\facelets\core\src\main\webapp
        Adding test\agnostic\facelets\core\src\main\webapp\WEB-INF
        Adding test\agnostic\facelets\core\src\main\webapp\WEB-INF\glassfish-web.xml
        Adding test\agnostic\facelets\core\src\main\webapp\WEB-INF\web.xml
        Adding test\agnostic\facelets\core\src\main\webapp\actionlistener.xhtml
        Adding test\agnostic\facelets\core\src\main\webapp\include.xhtml
        Adding test\agnostic\facelets\core\src\test
        Adding test\agnostic\facelets\core\src\test\java
        Adding test\agnostic\facelets\core\src\test\java\com
        Adding test\agnostic\facelets\core\src\test\java\com\sun
        Adding test\agnostic\facelets\core\src\test\java\com\sun\faces
        Adding test\agnostic\facelets\core\src\test\java\com\sun\faces\test
        Adding test\agnostic\facelets\core\src\test\java\com\sun\faces\test\agnostic
        Adding test\agnostic\facelets\core\src\test\java\com\sun\faces\test\agnostic\facelets
        Adding test\agnostic\facelets\core\src\test\java\com\sun\faces\test\agnostic\facelets\core
        Adding test\agnostic\facelets\core\src\test\java\com\sun\faces\test\agnostic\facelets\core\Issue2347IT.java
        Adding test\agnostic\facelets\pom.xml
        Sending test\agnostic\pom.xml
        Transmitting file data ........
        Committed revision 11364.

        Manfred Riem added a comment -

        Applied to 2.2 trunk,

        svn commit -m "Fixes http://java.net/jira/browse/JAVASERVERFACES-2681, migrating JAVASERVERFACES-2347 to new test harness."
        Deleting jsf-test\JAVASERVERFACES-2347
        Sending jsf-test\build.xml
        Adding test\agnostic\facelets
        Adding test\agnostic\facelets\core
        Adding test\agnostic\facelets\core\pom.xml
        Adding test\agnostic\facelets\core\src
        Adding test\agnostic\facelets\core\src\main
        Adding test\agnostic\facelets\core\src\main\java
        Adding test\agnostic\facelets\core\src\main\java\com
        Adding test\agnostic\facelets\core\src\main\java\com\sun
        Adding test\agnostic\facelets\core\src\main\java\com\sun\faces
        Adding test\agnostic\facelets\core\src\main\java\com\sun\faces\test
        Adding test\agnostic\facelets\core\src\main\java\com\sun\faces\test\agnostic
        Adding test\agnostic\facelets\core\src\main\java\com\sun\faces\test\agnostic\facelets
        Adding test\agnostic\facelets\core\src\main\java\com\sun\faces\test\agnostic\facelets\core
        Adding test\agnostic\facelets\core\src\main\java\com\sun\faces\test\agnostic\facelets\core\ActionListenerBean.java
        Adding test\agnostic\facelets\core\src\main\webapp
        Adding test\agnostic\facelets\core\src\main\webapp\WEB-INF
        Adding test\agnostic\facelets\core\src\main\webapp\WEB-INF\glassfish-web.xml
        Adding test\agnostic\facelets\core\src\main\webapp\WEB-INF\web.xml
        Adding test\agnostic\facelets\core\src\main\webapp\actionlistener.xhtml
        Adding test\agnostic\facelets\core\src\main\webapp\include.xhtml
        Adding test\agnostic\facelets\core\src\test
        Adding test\agnostic\facelets\core\src\test\java
        Adding test\agnostic\facelets\core\src\test\java\com
        Adding test\agnostic\facelets\core\src\test\java\com\sun
        Adding test\agnostic\facelets\core\src\test\java\com\sun\faces
        Adding test\agnostic\facelets\core\src\test\java\com\sun\faces\test
        Adding test\agnostic\facelets\core\src\test\java\com\sun\faces\test\agnostic
        Adding test\agnostic\facelets\core\src\test\java\com\sun\faces\test\agnostic\facelets
        Adding test\agnostic\facelets\core\src\test\java\com\sun\faces\test\agnostic\facelets\core
        Adding test\agnostic\facelets\core\src\test\java\com\sun\faces\test\agnostic\facelets\core\Issue2347IT.java
        Adding test\agnostic\facelets\pom.xml
        Sending test\agnostic\pom.xml
        Transmitting file data ..........
        Committed revision 11365.

        Manfred Riem added a comment -

        After migrating it to the new harness the client side state saving is failing. The real cause of the issue is the related JAVASERVERFACES-1828 issue.

        Manfred Riem added a comment -

        Stack trace when running with client side state saving:

        WARNING: StandardWrapperValve[Faces Servlet]: PWC1406: Servlet.service() for servlet Faces Servlet threw exception
        java.lang.ClassNotFoundException: com.sun.el.lang.VariableMapperImpl
        at org.glassfish.web.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1509)
        at org.glassfish.web.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1359)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:264)
        at com.sun.faces.renderkit.ApplicationObjectInputStream.resolveClass(ApplicationObjectInputStream.java:95)
        at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1593)
        at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1514)
        at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1750)
        at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1347)
        at java.io.ObjectInputStream.readObject(ObjectInputStream.java:369)
        at com.sun.el.MethodExpressionImpl.readExternal(MethodExpressionImpl.java:320)
        at java.io.ObjectInputStream.readExternalData(ObjectInputStream.java:1810)
        at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1769)
        at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1347)
        at java.io.ObjectInputStream.readObject(ObjectInputStream.java:369)
        at com.sun.faces.facelets.el.TagMethodExpression.readExternal(TagMethodExpression.java:158)
        at java.io.ObjectInputStream.readExternalData(ObjectInputStream.java:1810)
        at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1769)
        at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1347)
        at java.io.ObjectInputStream.readArray(ObjectInputStream.java:1685)
        at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1341)
        at java.io.ObjectInputStream.readArray(ObjectInputStream.java:1685)
        at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1341)
        at java.io.ObjectInputStream.readArray(ObjectInputStream.java:1685)
        at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1341)
        at java.io.ObjectInputStream.readObject(ObjectInputStream.java:369)
        at java.util.HashMap.readObject(HashMap.java:1155)
        at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at java.io.ObjectStreamClass.invokeReadObject(ObjectStreamClass.java:1004)
        at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1866)
        at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1771)
        at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1347)
        at java.io.ObjectInputStream.readObject(ObjectInputStream.java:369)
        at com.sun.faces.renderkit.ClientSideStateHelper.doGetState(ClientSideStateHelper.java:276)
        at com.sun.faces.renderkit.ClientSideStateHelper.getState(ClientSideStateHelper.java:219)
        at com.sun.faces.renderkit.ResponseStateManagerImpl.getState(ResponseStateManagerImpl.java:100)
        at com.sun.faces.application.view.FaceletPartialStateManagementStrategy.restoreView(FaceletPartialStateManagementStrategy.java:353)
        at com.sun.faces.application.StateManagerImpl.restoreView(StateManagerImpl.java:138)
        at com.sun.faces.application.view.ViewHandlingStrategy.restoreView(ViewHandlingStrategy.java:123)
        at com.sun.faces.application.view.FaceletViewHandlingStrategy.restoreView(FaceletViewHandlingStrategy.java:531)
        at com.sun.faces.application.view.MultiViewHandler.restoreView(MultiViewHandler.java:141)
        at com.sun.faces.lifecycle.RestoreViewPhase.execute(RestoreViewPhase.java:192)
        at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:101)
        at com.sun.faces.lifecycle.RestoreViewPhase.doPhase(RestoreViewPhase.java:116)
        at com.sun.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:118)
        at javax.faces.webapp.FacesServlet.service(FacesServlet.java:593)
        at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1550)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:281)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
        at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:655)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:595)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:161)
        at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:331)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:231)
        at com.sun.enterprise.v3.services.impl.ContainerMapper$AdapterCallable.call(ContainerMapper.java:317)
        at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:195)
        at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:860)
        at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:757)
        at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1056)
        at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:229)
        at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
        at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
        at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
        at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
        at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
        at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
        at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
        at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
        at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
        at java.lang.Thread.run(Thread.java:722)

        Manfred Riem added a comment -

        Waiting for upstream fix.

        Manfred Riem added a comment -

        Bumping priority since this issue is waiting for an upstream EL fix

        Manfred Riem added a comment -

        For Glassfish 4.0 the upstream EL was fixed so any new builds after today are fine.

        For Glassfish 3.1.2.2 you will need to manually patch your EL implementation, get the latest 2.2 from http://repo1.maven.org/maven2/org/glassfish/web/javax.el/


          People

          • Assignee:
            Manfred Riem
            Reporter:
            Manfred Riem
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: