javaserverfaces
  1. javaserverfaces
  2. JAVASERVERFACES-2738

Facelet XHTML loading is broken - still worked with 2.2.0-m08

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.2.0-m09
    • Fix Version/s: 2.1.20, 2.2.0-m10
    • Component/s: None
    • Labels:
      None

      Description

      To define the general layout we use Facelet tags implemented as XHTML using multiple levels of ui:composition/ui:decorate template="some/template.xhtml" and deliver that as a packaged jar to the applications.

      Since JSF 2.2.0-m09 this does not work anymore, with 2.2.0-m08 it still works. The templates referenced from XHTML Facelet component packaged into a jar cannot be resolved anymore. I get the following exception report:

      message /file:/C:/cs/ws4/mojarra_trunk/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/webapp/WEB-INF/lib/component-lib-0.0.1-SNAPSHOT.jar!/facelet/tag/layout.xhtml @16,50 <ui:decorate template="template/webapp.xhtml"> Invalid path : template/webapp.xhtml
      
      description The server encountered an internal error that prevented it from fulfilling this request.
      

      To investigate and fix the problem I developed a small reproducer application which I will attach to this issue.

        Issue Links

          Activity

          Manfred Riem added a comment -

          Applied to 2.2 trunk,

          svn commit -m "Fixes http://java.net/jira/browse/JAVASERVERFACES-2738, r=rogerk, revert changes done for relative paths for resource library contracts since they cause a regression."
          Sending jsf-ri\src\main\java\com\sun\faces\facelets\impl\DefaultFacelet.java
          Adding test\agnostic\facelets\cc\nb-configuration.xml
          Sending test\agnostic\facelets\cc\pom.xml
          Adding test\agnostic\facelets\cc\src\main\webapp\ccInJar.xhtml
          Adding test\agnostic\facelets\cc\src\main\webapp\templates
          Adding test\agnostic\facelets\cc\src\main\webapp\templates\defaultLayout.xhtml
          Adding test\agnostic\facelets\cc\src\main\webapp\templates\defaultPage.xhtml
          Adding test\agnostic\facelets\cc\src\test\java\com\sun\faces\test\agnostic\facelets\composite\Issue2738IT.java
          Adding test\agnostic\facelets\ccInJar
          Adding test\agnostic\facelets\ccInJar\pom.xml
          Adding test\agnostic\facelets\ccInJar\src
          Adding test\agnostic\facelets\ccInJar\src\main
          Adding test\agnostic\facelets\ccInJar\src\main\resources
          Adding test\agnostic\facelets\ccInJar\src\main\resources\META-INF
          Adding test\agnostic\facelets\ccInJar\src\main\resources\META-INF\ccInJar.taglib.xml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\layout.xhtml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template\layoutAll.xhtml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template\layoutContentBody.xhtml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template\layoutContentFooter.xhtml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template\layoutContentHead.xhtml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template\layoutContentLeft.xhtml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template\layoutHead.xhtml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template\webapp.xhtml
          Sending test\agnostic\facelets\pom.xml
          Sending test\agnostic\vdl\facelets\contracts\vhosts\src\test\java\com\sun\faces\test\agnostic\vdl\facelets\contracts\vhosts\Issue2511IT.java
          Sending test\agnostic\vdl\facelets\contracts\vhosts\src\test\java\com\sun\faces\test\agnostic\vdl\facelets\contracts\vhosts\Issue2679IT.java
          Transmitting file data ....................
          Committed revision 11624.

          Manfred Riem added a comment -

          Applied to 2.1 branch,

          svn commit -m "Fixes http://java.net/jira/browse/JAVASERVERFACES-2738, r=rogerk, backport of tests that assert behavior related to relative paths and composite components."
          Sending test\agnostic\facelets\cc\pom.xml
          Adding test\agnostic\facelets\cc\src\main\webapp\ccInJar.xhtml
          Adding test\agnostic\facelets\cc\src\main\webapp\templates
          Adding test\agnostic\facelets\cc\src\main\webapp\templates\defaultLayout.xhtml
          Adding test\agnostic\facelets\cc\src\main\webapp\templates\defaultPage.xhtml
          Adding test\agnostic\facelets\cc\src\test\java\com\sun\faces\test\agnostic\facelets\composite\Issue2738IT.java
          Adding test\agnostic\facelets\ccInJar
          Adding test\agnostic\facelets\ccInJar\pom.xml
          Adding test\agnostic\facelets\ccInJar\src
          Adding test\agnostic\facelets\ccInJar\src\main
          Adding test\agnostic\facelets\ccInJar\src\main\resources
          Adding test\agnostic\facelets\ccInJar\src\main\resources\META-INF
          Adding test\agnostic\facelets\ccInJar\src\main\resources\META-INF\ccInJar.taglib.xml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\layout.xhtml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template\layoutAll.xhtml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template\layoutContentBody.xhtml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template\layoutContentFooter.xhtml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template\layoutContentHead.xhtml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template\layoutContentLeft.xhtml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template\layoutHead.xhtml
          Adding test\agnostic\facelets\ccInJar\src\main\resources\facelet\tag\template\webapp.xhtml
          Sending test\agnostic\facelets\pom.xml
          Transmitting file data ................
          Committed revision 11625.


            People

            • Assignee:
              Manfred Riem
              Reporter:
              Hanspeter Duennenberger
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: